YPSET(8) BSD System Manager's Manual YPSET(8)NAME
ypset -- tell ypbind(8) which YP server process to use
ypset [-h host] [-d domain] server
Ypset tells the ypbind(8) process on the current machine which YP server process to communicate with. If server is down or is not running a
YP server process, it is not discovered until a YP client process attempts to access a YP map, at which time ypbind(8) tests the binding and
takes appropriate action.
Ypset is most useful for binding a YP client that is not on the same broadcast network as the closest YP server, but can also be used for
debugging a local network's YP configuration, testing specific YP client programs, or binding to a specific server when there are many
servers on the local network supplying YP maps.
The options are as follows:
Set the YP binding on host instead of the local machine.
Use the YP domain domain instead of the default domain as returned by domainname(1).
SEE ALSO domainname(1), ypbind(8), ypcat(1), ypmatch(1), yppoll(8), ypwhich(1), yp(8)AUTHOR
Theo de Raadt
BSD October 25, 1994 BSD
Check Out this Related Man Page
ypset(8) System Manager's Manual ypset(8)NAME
ypset - bind ypbind to a particular NIS server
ypset [ -d domain ] [ -h hostname ] server
In order to run ypset, ypbind must be initiated with the -ypset or -ypsetme options. See ypbind(8). ypset tells ypbind to get NIS ser-
vices for the specified domain from the ypserv(8) process running on server.
In cases where several hosts on the local net are supplying NIS services, it is possible for ypbind to rebind to another host even while
you attempt to find out if the ypset operation succeeded. For example, you can type:
example% ypset host1
which can be confusing. This is a function of the NIS subsystem's attempt to know always a running NIS server, and occurs when host1 does
not respond to ypbind because it is not running ypserv (or is overloaded), and host2, running ypserv, gets the binding.
Server indicates the NIS server to bind to, and must be specified as a name or an IP address. This will work only if the node has a cur-
rent valid binding for the domain in question, and ypbind has been set to allow use of ypset. In most cases, server should be specified
as an IP address.
OPTIONS -d domain
Specify a domain other than the default domain as returned by domainname(1).
Set the NIS binding on host hostname
instead of the local machine.
SEE ALSO domainname(8), ypbind(8), ypcat(8), ypmatch(1), ypserv(8), yppoll(8), ypwhich(1)AUTHOR
ypset is part of the yp-tools package, which was written by Thorsten Kukuk <firstname.lastname@example.org>.
YP Tools 2.7 May 1998 ypset(8)
Is there an easy way (besides samba) to send a file from a unix server to a win98 machine across a network. I am on a SCO server and need to send the file to a windows machine so the program on the machine does not keep on looking for it on my server. It checks for a new file every couple of... (5 Replies)
Is there a simple way to copy data from one server to a different server?
Seems that if 2 servers are on the same network, there should be a simple way to copy between the two.
Not just one file. I need to copy a whole directory with subdirectories from one server to a different one.
I... (9 Replies)
We have an old Axil running SunOS Release 5.5.1. Recently, we updated our network, so the gateway and domain changed. Our network admin forgot (or didn't know) that we had this machine on the network, so it quietly lost its mind.
Now we are trying to add it back to the network. He... (5 Replies)
I have purchased a Dec unix Ver 3.2c machine that is about ten years old. I need to get this machine on our network (windows 2003 domain) so I can copy files to it. I know I need to change the IP address, but where and how do I change it? What else do I chang?
Thanks Randy (8 Replies)
I have NTS server with GMT time ,I want to make this server as a time reference for all unix servers that I have in my network.I knew 'ntpdate' command but what I need is to make the time on unix servers in my country local time which is GMT+3???Any help??
Thanks in advance (14 Replies)
Looking at the asio.sourceforge.net library, I found a tutorial to develop simple client and server programs. Below I am pasting the client and the server. On my Fedora Core 4, I can compile the two programs(client is 'a' and server is 'daytime', but I have no idea on how to test them... ... (8 Replies)
I am working on Solaris sparc 9 and my computer name is mgsun.
I want to bring this machine to a specific domain (e.g.-xx.xx.org).
So please help me to do the same..
thanks in Advance... (4 Replies)
hello, i am new to unix and need support</SPAN></SPAN>
</SPAN></SPAN>The problem is:
I have a SCO 5.0.5 server, and has no local network access, I think my problem are the drivers for network card.
my network card is Kingston EtheRx PCI Fast Ethernet Adapter KNE120TX and already installed the... (9 Replies)
im trying to configure samba on linux server so win client can access the shared files but my win client is on diffrent domain , we recently changed our domain name but not for certain servers...
i guess the samba linux server is still part of our sub domain which is why i still can access... (4 Replies)
a server with RHEL 5.3 is running.
im going to access this via putty but get message
"server unexpectedly closed network connection". after some time.
same is the case with root and oracle user.
what can be issue ? (7 Replies)
We have a process on our Linux RedHat machine creating symbolic links and moving around some files from domain to domain. The issue is that the programmer has left a long time ago and nobody knows how the program is called, where it is and how the scheduling is setup. It runs every day for... (7 Replies)
Hopefully someone can help.
We have a process that writes a file using Connect Direct to our local Solaris server and then our C++ program will pick up the file and process it. Unfortunately, because of the size of the file, the C++ program is processing the file before it has finished... (7 Replies)
I'm writing a script on a Solaris 10 server (server A) that needs to telnet 2 servers (server B & server C) and get a certain process count from these 2 servers.
Then on server A, I check if both counts are greater than 17, I do a sendmail to concerned people.
For the telnet part,... (7 Replies)