xgridctl(8) BSD System Manager's Manual xgridctl(8)NAME
xgridctl -- Xgrid Daemon Control Interface
xgridctl [target] action
The optional target is one of the following:
controller perform the action for the xgricontrollerd daemon
agent perform the action for the xgridagentd daemon
The action is one of the following:
status print status for the chosen daemon, or print status for all daemons if no target is specified
start enable and start the chosen daemon, or start all enabled daemons if no target is specified
stop disable and stop the chosen daemon, or stop all daemons if no target is specified
restart stop and then enable and start the chosen daemon, or stop all daemons and then start all enabled daemons if no target is speci-
0 completed succesfully
1 an error occurred
agent launchd control file
controller launchd control file
Print status of agent and controller:
$ xgridctl status
Start the controller and set it to run at startup:
$ xgridctl controller start
Stop the agent and set it to not run at startup:
$ xgridctl agent stop
SEE ALSO xgrid(1)launchd(8)HISTORY
This program was first introduced in Mac OS X 10.4 "Tiger". It was inspired by apachectl(8). The "on" and "off" actions were deprecated in
Mac OS X 10.5 "Leopard".
Bug reports can be sent to bugreport.apple.com
Mac OS X April 2, 2009 Mac OS X
Check Out this Related Man Page
taskgated(8) BSD System Manager's Manual taskgated(8)NAME
taskgated -- task_for_pid access control daemon
taskgated [-s] [-t timeout] [-i pid]
taskgated is a system daemon that implements a policy for the task_for_pid system service. When the kernel is asked for the task port of a
process, and preliminary access control checks pass, it invokes this daemon (via launchd) to make the decision.
OPTIONS -t timeout
The daemon will quit after that many seconds of inactivity. It will be relaunched by launchd as needed. A timeout of zero can be
specified to make the daemon quit after servicing each request, but a small positive timeout is better for performance.
-i pid Inject the service port of taskgated into the process with the given pid, rather than relying on launchd to install it system-wide.
This is for testing only, and requires the launchd configuration for taskgated to be removed.
system.privilege.taskport Authorization right used to check access of allowed (but not safe) callers.
SecTaskAccess A value of "allowed" is required for any program that wants access to task ports. A value of "safe" bypasses authorization
checks if so configured. Code must be signed by any system-trusted signing authority.
/etc/authorization to configure the authorization used.
startup configuration file for taskgated
SEE ALSO security(1), launchd(8)HISTORY
taskgated was first introduced in Mac OS 10.5 (Leopard).
Procmod and procview support (-p) was removed in 10.11.
Certain software updates of Mac OS 10.4 (Tiger) introduced the convention requiring membership in the procmod or procview groups to control
task port access. Before that, any process could obtain the task port of any other process with the same user-id.
Darwin June 1, 2019 Darwin
i just realise that everytimes i boot up my sun solaris 8 sparc, i need to explicitly run the following comand to start up my snmp agent.
i just wonder that how to make it auto-startup once the machine is boot up.
please enlighten me.... (1 Reply)
I have been a Macintosh user for many, many years. As you may know the latest MacOS ( OS X ) is UNIX based. (Please see http://www.apple.com/macosx/technologies/inside.html for more information.) Basically, I really have no idea where to start with UNIX...if anyone could take a quick... (7 Replies)
Can I run a UNIX executable on Mac OS X Tiger?
If so, how is it done?
I FTP'd my schools UNIX server some C++ code and header files. Then I used Telnet to get g++ to compile them.
I then FTP'd the UNIX executable back to my PowerBook G4.
I've already... (4 Replies)
can somebody give me a definition for daemons, or example what are they !!
and what the use for?
i've done some research and all what i found is /etc/...
and i haven't quietly got the concept.
any ideas !!
Thanks. (5 Replies)
I get an error when I run the command apachectl status or apachectl fullstatus
here's the error:
Unfortunately, your browser is not supported by Sitebuilder.
Please use Internet Explorer 5.5 or later, or Mozilla.
Already tried to install lynx and enabled ExtendedStatus to On... (1 Reply)
Replace an unknown status controller on HP FC60 disk array
The users detected that the status of controller at A is unknown.
Analysis and diagnostic:
Physical observed all leds on enclosure of disk array is normal.
The... (4 Replies)
Frequently we need to stop or start services on Linux systems.
For exmaple : To start or stop vsftpd daemon
# /etc/init.d/vsftpd start
# /etc/init.d/vsftpd stop
Following script will check the vsftpd service and if it is running, it will be stopped or vice-versa.
# cat... (5 Replies)
Tiger Woods has won his 15th major championship and his 5th Masters, shaping and creating the best sports comeback story of our time.
Tiger's story should inspire everyone in the world to fight everyday of your life for what you love and what you believe in... (0 Replies)
Yesterday someone asked me to install TeamViewer and share my Mac screen with them while on a conference call.
I shut down my Mac before sleeping and woke up to some major problem with my 12-core CPU in hyperdrive, and the system activity monitor showed my Mac kernel_task was at 1,200% and the... (30 Replies)