VSDBUTIL(8) BSD System Manager's Manual VSDBUTIL(8)NAME
vsdbutil -- manipulates the volume status DB.
vsdbutil [-a path]
vsdbutil [-c path] [-d path] [-i]
vsdbutil manipulates the volume status DB. The following options are available:
-a adopts (activates) on-disk ownership on the specified path
-c checks the status of the ownership usage on the specified path
-d disowns (deactivates) the on-disk ownership on the specified path
-i initializes the ownership database to include all mounted HFS+ volumes
-h prints out a simple help message
The vsdbutil command is deprecated; using a volume UUID in fstab(5) is preferred.
/var/db/volinfo.database Database of volumes managed via vsdbutil.
SEE ALSO diskutil(8), mount(8), fstab(5)Darwin December 19, 2001 Darwin
Check Out this Related Man Page
HFS(1) General Commands Manual HFS(1)NAME
hfs - shell for manipulating HFS volumes
hfs [hfs-path [partition-no]]
hfs is an interactive command-oriented tool for manipulating HFS volumes. hfs is based on the Tcl interpreter, so basic Tcl constructs can
be used in addition to the following commands:
mount path [partition-no]
The specified UNIX path is opened as an HFS volume. If a partition number n is specified and the volume source is located on a par-
titioned medium, the nth discovered HFS partition will be mounted. The default partition-no is 1.
The volume previously mounted from the specified path (or the current volume, if none specified) is unmounted.
The volume previously mounted from the specified path is made current.
info General information about the currently mounted volume is displayed. This information is also displayed automatically when the vol-
ume is mounted.
pwd The full path to the current working HFS directory is displayed.
The current working directory is changed to the given HFS path. If no path is given, the working directory is changed to the root of
A directory listing of the specified HFS directory is displayed. If no path is given, the contents of the current working directory
A new, empty directory is created with the specified path.
The specified directory is removed. It must be empty.
create hfs-path [type [creator]]
An empty file is created with the specified path. The Macintosh type and creator may be specified, or they will default to TEXT and
Both forks of the specified file are deleted.
Status information about the specified HFS path-identified entity is displayed.
The data fork of the specified HFS file is displayed.
copyin unix-path [hfs-path [mode]]
The specified UNIX file is copied to the named HFS destination path. Unless specified otherwise, the file will be copied into the
current HFS working directory using a heuristically chosen mode. The mode may be one of: macb (MacBinary II), binh (BinHex), text,
copyout hfs-path [unix-path [mode]]
The specified HFS file is copied into the named UNIX destination path. Unless specified otherwise, the file will be copied into the
current UNIX working directory using a heuristically chosen mode. The modes are the same as for copyin.
format path [partition-no [volume-name]]
The specified UNIX path is initialized as an empty HFS volume with the given name, and this volume is subsequently mounted. The
default volume name is Untitled.
The shell is scriptable, however it should be understood that the above commands are actually implemented by Tcl procedures prefixed with
the character "h", e.g. hmount, hcd, etc., in order to avoid name collisions with other Tcl utilities. The "h" may be omitted in interac-
tive use for convenience.
SEE ALSO hfsutils(1), xhfs(1)BUGS
cat can only display the data fork of a file. Text translations are performed unconditionally on the output. Furthermore, binary data can-
not be handled properly from within Tcl scripts since the character with value 0 cannot be represented in Tcl strings. Use copyout to copy
files without these limitations.
Robert Leslie <email@example.com>
HFSUTILS 15-Jan-1997 HFS(1)