UPSSHUTDOWN(8) BSD System Manager's Manual UPSSHUTDOWN(8)NAME
upsshutdown -- UPS emergency low power shutdown script
DESCRIPTION
upsshutdown is a script that runs automatically when the system performs an emergency UPS low power shutdown. The script is run before
shutdown(8) is invoked. upsshutdown only runs if one of the three shutdown rules is enabled and true: "percentage remaining," "time remain-
ing," or "time since loss of power." These settings can be changed using pmset(1) or Energy Saver in System Preferences.
The system administrator may modify upsshutdown. The script should only contain commands that must run in the case of an emergency UPS shut-
down. It should not contain any commands that would otherwise be executed during a normal shutdown since the normal shutdown procedure fol-
lows invocation of upsshutdown.
LOCATION
/usr/libexec/upsshutdown
SEE ALSO pmset(1), ioupsd(8)Darwin October 25, 2005 Darwin
Check Out this Related Man Page
REBOOT(8) BSD System Manager's Manual REBOOT(8)NAME
halt, reboot -- stopping and restarting the system
SYNOPSIS
halt [-lnqu]
reboot [-lnq]
DESCRIPTION
The halt and reboot utilities flush the file system cache to disk, send all running processes a SIGTERM (and subsequently a SIGKILL) and,
respectively, halt or restart the system. The action is logged, including entering a shutdown record into the wtmp(5) file.
When the system is halted with the halt command, the system is powered off.
The options are as follows:
-l The halt or reboot is not recorded in the system log. This option is intended for applications such as shutdown(8), that call reboot
or halt and log this themselves.
-n The file system cache is not flushed. This option should probably not be used.
-q The system is halted or restarted quickly and ungracefully, and only the flushing of the file system cache is performed (if the -n
option is not specified). This option should probably not be used.
-u The system is halted up until the point of removing system power, but waits before removing power for 5 minutes so that an external
UPS (uninterruptible power supply) can forcibly remove power. This simulates a dirty shutdown to permit a later automatic power on.
OS X uses this mode automatically with supported UPSs in emergency shutdowns.
Normally, the shutdown(8) utility is used when the system needs to be halted or restarted, giving users advance warning of their impending
doom and cleanly terminating specific programs.
SIGTERM TO SIGKILL INTERVAL
The SIGKILL will follow the SIGTERM by an intentionally indeterminate period of time. Programs are expected to take only enough time to
flush all dirty data and exit. Developers are encouraged to file a bug with the OS vendor, should they encounter an issue with this func-
tionality.
SEE ALSO wtmp(5), shutdown(8), sync(8)HISTORY
A reboot utility appeared in Version 6 AT&T UNIX.
BSD June 9, 1993 BSD
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)