UPDATE(8) BSD System Manager's Manual UPDATE(8)NAME
update -- flush internal filesystem caches to disk frequently
The update utility has been incorporated into launchd(8). It historically helped protect the integrity of disk volumes by flushing volatile
cached filesystem data to disk at thirty second intervals using the sync(2) function call.
SEE ALSO sync(2), fsck(8), launchd(8), sync(8)BUGS
It is possible on some systems that a sync occurring simultaneously with a crash may cause file system damage. See fsck(8).
An update utility appeared in Version 6 AT&T UNIX.
BSD August 18, 2008 BSD
Check Out this Related Man Page
sync(2) System Calls sync(2)NAME
sync - update super block
The sync() function writes all information in memory that should be on disk, including modified super blocks, modified inodes, and delayed
Unlike fsync(3C), which completes the writing before it returns, sync() schedules but does not necessarily complete the writing before
The sync() function should be used by applications that examine a file system, such as fsck(1M), and df(1M), and is mandatory before
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Interface Stability |Standard |
SEE ALSO df(1M), fsck(1M), fsync(3C), attributes(5), standards(5)SunOS 5.11 5 Jul 1990 sync(2)
I have followed instructions to get the jdk for sparc, 1.3 loaded on this sparc workstation machine. I used a tar file and everything seemed to go fine. The usr/j2se directory was created with all the subdirectories and java files. However, attempting to run Java commands fails with a file not... (18 Replies)
I am trying to update a MASTER file by a NEW file which may contain fewer records.
The update should use a key (2 first fields), here is a senario:
the result should be:
can you recommend me a way to do it?
Y.N. (25 Replies)
Hello, i am bit stuck with making script for automatic procedure.
Two files. One is flat file, other is csv file.
csv file has two column/fields with comma delimited data.
Here is what i need (explained way)
field1 | field2
"hello2","byebye2"... (23 Replies)
I am writing a software product and hope that it will work on a variety of Linux distributions. At the moment, I am trying to create some kind of Linux version of patches/upgrades of installed software. Gathering information on available updates isn't hard, nor is installation of updates, but I... (27 Replies)
I am running on Ubuntu 12 (precise) 64 bit and came to know that i cannot install any packages using apt-get and aptitude.
Linux test01 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
But the same /etc/apt/sources.list file is... (20 Replies)
I have a sun v880 that i got from ebay for cheap as a way to to learn Solaris and sun hardware in general.
The machine currently has OBP 4.7.0 2002/10/25 and i was wondering if there was a way to update the prom with out and active solaris install, as currently when i proceed with the... (29 Replies)
I'm completely new to bash scripting and still learning my way through albeit vey slowly.
I need to know where to insert my server names', my ip address numbers through out the script alas to no avail.
I'm also searching on how to save .sh (bash shell) script properly.... (25 Replies)
I am trying to match $1 in file1 with $2 in file2. If a match is found then $3 and $4 of file2 are copied to file1. Both files are tab-delimeted and I am getting a syntax error and would also like to update file1 in-place without creating a new file, but am not sure how. Thank you :).
... (19 Replies)
I have a listfile contains list of files path.
i need to read the line of the listfile
mv the file to other directory
and update the listfile by deleting the lines of the listfile.
while read -r line || ];
mv $line... (19 Replies)
I moved the user information in the top right on the navbar to side panel and replace it with a clickable avatar image. If you have an avatar, you will see your avatar and if you don't you will see some default one (will change it to something better later).
If you have any notification... (53 Replies)
Upgrade (step 1) the posts, by putting a "user info" icon in the top right and making it so it toggles the user info.
The user info icon has a badge which shows the number of posts. I will have to dig around in the code more to get the total posts thanks and other badges working; but... (22 Replies)