Query: store
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
STORE(9) BSD Kernel Developer's Manual STORE(9)NAMEstore, subyte, suswintr, suword -- store data to user-spaceSYNOPSIS#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> int subyte(volatile void *base, int byte); int suword(volatile void *base, long word); int suword16(volatile void *base, int word); int suword32(volatile void *base, int32_t word); int suword64(volatile void *base, int64_t word); #include <sys/resourcevar.h> int suswintr(void *base, int word);DESCRIPTIONThe store functions are designed to copy small amounts of data to user-space. If write is successful, it is performed atomically. The data written must be naturally aligned. The store routines provide the following functionality: subyte() Stores a byte of data to the user-space address base. suword() Stores a word of data to the user-space address base. suword16() Stores 16 bits of data to the user-space address base. suword32() Stores 32 bits of data to the user-space address base. suword64() Stores 64 bits of data to the user-space address base. suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context.RETURN VALUESThe store functions return 0 on success or -1 on failure.SEE ALSOcopy(9), fetch(9)BSDOctober 29, 2014 BSD
Related Man Pages |
---|
subyte(9) - freebsd |
suword(9) - debian |
suword32(9) - freebsd |
suword64(9) - freebsd |
suword(9) - freebsd |
Similar Topics in the Unix Linux Community |
---|
How to delete the last word in a file? |
Grepping word based on white space..... |
Awk for last word |
SSL Certificate Stores |
Certificates in Stores |