SHOWMOUNT(8) BSD System Manager's Manual SHOWMOUNT(8)NAME
showmount -- show remote NFS mounts on host
showmount [-Ae36] [-a | -d] [host]
showmount shows status information about the NFS server on host. By default it prints the names of all hosts that have NFS file systems
mounted on the host. See NFS: Network File System Protocol Specification, RFC 1094, Appendix A, and NFS: Network File System Version 3
Protocol Specification, Appendix I, for a detailed description of the protocol.
-A Search for NFS servers advertised via Bonjour.
-a List all mount points in the form: host:dirpath
-d List directory paths of mount points instead of hosts.
-e Show the host's exports list.
-3 Use mount protocol Version 3, compatible with NFS Version 3.
-6 Use only IPv6 addresses to contact servers.
SEE ALSO mount(1), mountd(8), nfsd(8), mDNSResponder(8)BUGS
The mount daemon running on the server only has an idea of the actual mounts, since the NFS server is stateless. showmount will only display
the information as accurately as the mount daemon reports it.
The showmount utility first appeared in 4.4BSD.
4th Berkeley Distribution September 26, 2010 4th Berkeley Distribution
Check Out this Related Man Page
SHOWMOUNT(8) System Manager's Manual SHOWMOUNT(8)NAME
showmount - show mount information for an NFS server
showmount [ -adehv ] [ --all ] [ --directories ] [ --exports ] [ --help ] [ --version ] [ host ]
showmount queries the mount daemon on a remote host for information about the state of the NFS server on that machine. With no options
showmount lists the set of clients who are mounting from that host. The output from showmount is designed to appear as though it were pro-
cessed through ``sort -u''.
OPTIONS -a or --all
List both the client hostname or IP address and mounted directory in host:dir format. This info should not be considered reliable.
See the notes on rmtab in rpc.mountd(8).
-d or --directories
List only the directories mounted by some client.
-e or --exports
Show the NFS server's export list.
-h or --help
Provide a short help summary.
-v or --version
Report the current version number of the program.
Suppress the descriptive headings from the output.
SEE ALSO rpc.mountd(8), rpc.nfsd(8)BUGS
The completeness and accuracy of the information that showmount displays varies according to the NFS server's implementation.
Because showmount sorts and uniqs the output, it is impossible to determine from the output whether a client is mounting the same directory
more than once.
Rick Sladkey <firstname.lastname@example.org>
6 October 1993 SHOWMOUNT(8)
below is the software list of lines I have,
MozillaSrc 1.7.8.00.00 Mozilla 1.78 Source Distribution
NFS B.11.11 ONC/NFS; Network-File System,Information Services,Utilities
NParProvider B.11.11.01.04.01.01 nPartition Provider
NPartition ... (7 Replies)
can anyone help me out in extracting the pattern from a file...
The Input file is:
NFS B.11.11 ONC/NFS; Network-FileSystem,InformationServices,Utilities|123
NParProvider B.11.11.01.04.01.01 nPartition Provider|456
NPartition A.01.02 Enhanced NPartition Commands/789... (6 Replies)
In my new job i have 5 servers running AIX 5.3.
In the 1st one (BackupSRV) i have a partition (from SAN) mounted on /arquive.
This partition its configured with NFS to be used by the other 4 servers.
In the 3 servers i can mount without any problems.
The 4rd one it gives me an... (8 Replies)
I am facing a problem with NFS after doing the HACMP configuration
Issue : The showmount -e pr2serv at pr1serv ,it is only showing 1 mount exported /oracle , instead of showing all 7 as per /etc/exports file.
issue : while mounting /oracle at pr1serv getting permission... (8 Replies)
I ‘m beginner on unix
I want to move an unix aix post 5.2 on distant site for use catia V4 with a foundation of data accommodated by a serveur windows 2003 and an environment accommodated on the serveur aix.
The computer was linked up by IP (22.214.171.124) with waiter 2003 (via NFS) and the waiter... (8 Replies)
At work I have two sets of systems, my Primary network and Secondary network. Each consists of 4 servers, 3 of them for doing work (Idaho, Omaha, Juno) and hosting the processes we work on and 1 holds all the home directories (Sword). So Idaho, Omaha and Juno use Sword for home directories (user... (7 Replies)
I have more than 20 servers available in different locations and I want to configure CD Rom as NFS between these servers to be sharedCan any one explain the configuration how can NFS or share CD rom between more than 20 servers available in different locationsto be used in one time from all... (5 Replies)
I have two mount points have the same data with little changes between them
Both of them have the same data, there is some little changes on the data between them
I want /appabc2 to has the same data of /appabc1 exactly including to those little changes... (6 Replies)
I have a server suse 11 two IP different segments
one IP is point to point to NFS Storage.
Administration IP: 10.7.10.100
NFS-Storage IP: 192.168.10.50
weird thing is I defined the NFS I can mount them using mount -a but when I reboot the server the NFS mount points are not there... (11 Replies)
I am not sure is this plausible...
I have just built a NFS master server on a solaris box (secured by NIS)
And I have a dozen of virtual machines running 32 and 64 bits linux and windows, running different types of servers.
I am not sure is it possible to move most of the programs to the... (6 Replies)
I am running CentOS 6.3 as a VM on a host which has the same installation. I configured my NFS server and I am guessing it works. I say guessing because I can mount the desired folder with mount command on my client machine. So, when I run:
mount -t nfs -o vers=3 vm2.domain.com:/nethome /nethit... (7 Replies)
i backed up a test LPAR using mksyb utility on AIX. and transferred it to NIM server via NFS.
I want to create a SPOT using this mksysb . Please explain me the procedure. And got something online, but that procedure is different.
Please respond. (5 Replies)
When i export the directory where the data really is, i can specify which hosts can mount it. On the remote server i create a mount point directory and then mount it to the source servers directory (that has the data).
I need to run my script on Server X , i would login there and type in the... (11 Replies)