ServerPerfLog(8) BSD System Manager's Manual ServerPerfLog(8)NAME
ServerPerfLog -- Server Performance logging daemon.
SYNOPSIS
ServerPerfLog
DESCRIPTION
The Server Performance log daemon writes a variety of server performance information into the Apple System Log facility for use by Server.app
and other programs that report on system performance.
This data is logged as Alert messages into com.apple.performance Facility in the ASL database. Data is recorded in ASL with Sender set to
ServerPerf.
FILES
/usr/libexec/ServerPerfLog
Daemon.
/System/Library/LaunchDaemons/com.apple.ServerPerfLog.plist
Launchd plist.
SEE ALSO asl(3)HISTORY
First shipped in 10.7.
Darwin June 2, 2019 Darwin
Check Out this Related Man Page
ReportCrash(8) BSD System Manager's Manual ReportCrash(8)NAME
ReportCrash -- Generates crash reports
SYNOPSIS
ReportCrash
DESCRIPTION
ReportCrash analyzes crashing processes and saves a crash report to disk. A crash report contains information that can help a developer
diagnose the cause of a crash. ReportCrash also records the identity of the crashing process and the location of the saved crash report in
the system.log and the ASL log database.
ReportCrash is invoked automatically by launchd when a crash is detected. For applications and other processes running in the per-user
launchd context, ReportCrash runs as a LaunchAgent and saves crash reports in the user's ~/Library/Logs/DiagnosticReports/ directory. For
daemons, other processes running in the system launchd context and other privileged processes, ReportCrash runs as a LaunchDaemon and saves
crash reports in the system's /Library/Logs/DiagnosticReports directory where they are only readable by admin users. If there are too many
crash reports saved for a particular process, older reports will automatically be removed in order to conserve disk space.
launchtl can be used to disable and re-enable crash reporting. To disable crash reporting:
launchctl unload -w /System/Library/LaunchAgents/com.apple.ReportCrash.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.ReportCrash.Root.plist
To re-enable crash reporting:
launchctl load -w /System/Library/LaunchAgents/com.apple.ReportCrash.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.ReportCrash.Root.plist
For application crashes (but not background process crashes) ReportCrash will display a dialog notifying the user that the application unex-
pectedly quit and offering to reopen the application or send the report to Apple. For developers, the behavior of this dialog can be
adjusted using /Developer/Applications/Utilities/CrashReporterPrefs.app which is installed as part of the developer tools.
Crash reports which are sent to Apple are submitted anonymously by the SubmitDiagInfo process. The reports are used by Apple to improve its
products. Users who need support should use http://www.apple.com/support or other authorized support channels. Developers who are ADC mem-
bers should report bugs using http://bugreporter.apple.com in order to allow for two way communication between Apple and the bug reporter.
More information about interpreting the contents of crash reports can be found in Technote 2123: https://developer.apple.com/library/con-
tent/technotes/tn2004/tn2123.html
SEE ALSO launchd(8), launchd.plist(8), launchctl(8), spindump(8), SubmitDiagInfo(8)Mac OS June 1, 2019 Mac OS
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)