PMAP_DUMP(8) BSD System Manager's Manual PMAP_DUMP(8)NAME
pmap_set -- set the list of registered RPC programs
The pmap_set command can be used to restart a running portmapper or to set the list of registered RPC programs on the local host. If you want
to use the program to restart the portmapper you have to redirect the output of to a file. After this you can restart the portmapper and
restore the list of the registered RPC programs by feeding the output of to the pmap_set command.
SEE ALSO pmap_dump(8), portmap(8)Darwin December 12, 2002 Darwin
Check Out this Related Man Page
rpcinfo(8) System Manager's Manual rpcinfo(8)NAME
rpcinfo - report remote procedure call (RPC) information
/usr/sbin/rpcinfo -p [host]
/usr/sbin/rpcinfo [-n portnum] -u host program-number [version-number]
/usr/sbin/rpcinfo [-n portnum] -t host program-number [version-number]
/usr/sbin/rpcinfo -b program-number version-number
/usr/sbin/rpcinfo -d program-number version-number
Makes an RPC broadcast to procedure 0 of the specified program and version using UDP and report all hosts that respond. Deletes registra-
tion for the RPC service of the specified program and version. This option can be executed only by the superuser. Uses portnum as the port
number for the -t and -u options instead of the port number given by the portmapper. Probes the portmapper portmap(8), running on host,
and print a list of all registered RPC programs. If host is not specified, rpcinfo defaults to the value returned by either hostname(1) or
gethostname(2). Makes an RPC call to procedure 0 of program-number using the user datagram protocol (UDP), and report whether a response
was received. Makes an RPC call to procedure 0 of program-number using the transmission control protocol (TCP), and report whether a
response was received.
The rpcinfo command makes a remote procedure call (RPC) call to an RPC server and displays its findings based on the specified options.
The program-number argument can be either a name or a number. If a version is specified, rpcinfo attempts to call that version of the
specified program. Otherwise, rpcinfo attempts to find all the registered version numbers for the specified program by calling version 0.
If version 0 exists, rpcinfo attempts to obtain this information by calling an extremely high version number. The rpcinfo command then
attempts to call each registered version.
To show all of the RPC services registered on the local machine, use: # rpcinfo -p To ping the mountd service registered on the machine
named klaxon, use: # rpcinfo -u klaxon mountd To show all machines on the local network that are running the ypserv daemon, use: # rpcinfo
-b ypserv 'version' | uniq
where 'version' is the current NIS version obtained from the results of the -p option. To delete the registration for version 1 of
the ypbind daemon, use: # rpcinfo -d walld 1
Names for RPC program numbers
Commands: hostname(1), portmap(8)
Networking: tcp(7), udp(7)rpcinfo(8)