PLAINRSA-GEN(8) BSD System Manager's Manual PLAINRSA-GEN(8)NAME
plainrsa-gen -- generator for Plain RSA keys
SYNOPSIS
plainrsa-gen [-b bits] [-e pubexp] [-f outfile] [-h]
DESCRIPTION
plainrsa-gen can be used to generate Plain RSA keys for authentication purposes. Using Plain RSA keys is optional. Other possibilities are
Pre-shared keys or X.509 certificates.
-b bits
bit length of the key. Default is 1024, recommended length is 2048 or even 4096 bits. Note that generating longer keys takes more
time.
-e pubexp
value of the RSA public exponent. Default is 0x3. Don't change this unless you really know what you are doing!
-f outfile
write the resulting key to outfile instead of stdout. If the file already exists it won't be overwritten. You wouldn't like to lose
your private key by accident, would you?
OUTPUT FILE FORMAT
This is the secret private key that should never leave your computer:
: RSA {
# RSA 1024 bits
# pubkey=0sAQOrWlcwbAIdNSMhDt...
Modulus: 0xab5a57306c021d3523...
PublicExponent: 0x03
PrivateExponent: 0x723c3a2048...
Prime1: 0xd309b30e6adf9d85c01...
Prime2: 0xcfdc2a8aa5b2b3c90e3...
Exponent1: 0x8cb122099c9513ae...
Exponent2: 0x8a92c7071921cd30...
Coefficient: 0x722751305eafe9...
}
The line pubkey=0sAQOrW... of the private key contains a public key that should be stored in the other peer's configuration in this format:
: PUB 0sAQOrWlcwbAIdNSMhDt...
You can also specify from and to addresses for which the key is valid:
0.0.0.0/0 10.20.30.0/24 : PUB 0sAQOrWlcwbAIdNSMhDt...
SEE ALSO racoon.conf(5), racoon(8)HISTORY
plainrsa-gen was written by Michal Ludvig <michal@logix.cz> and first appeared in ipsec-tools 0.4.
BSD June 14, 2004 BSD
Check Out this Related Man Page
PLAINRSA-GEN(8) BSD System Manager's Manual PLAINRSA-GEN(8)NAME
plainrsa-gen -- generator for Plain RSA keys
SYNOPSIS
plainrsa-gen [-b bits] [-e pubexp] [-f outfile] [-h]
DESCRIPTION
plainrsa-gen can be used to generate Plain RSA keys for authentication purposes. Using Plain RSA keys is optional. Other possibilities are
Pre-shared keys or X.509 certificates.
-b bits
bit length of the key. Default is 1024, recommended length is 2048 or even 4096 bits. Note that generating longer keys takes longer
time.
-e pubexp
value of RSA public exponent. Default is 0x3. Don't change this unless you really know what you are doing!
-f outfile
outfile instead of stdout. If the file already exists it won't be overwritten. You wouldn't like to lose your private key by acci-
dent, would you?
OUTPUT FILE FORMAT
This is the secret private key that should never leave your computer:
: RSA {
# RSA 1024 bits
# pubkey=0sAQOrWlcwbAIdNSMhDt...
Modulus: 0xab5a57306c021d3523...
PublicExponent: 0x03
PrivateExponent: 0x723c3a2048...
Prime1: 0xd309b30e6adf9d85c01...
Prime2: 0xcfdc2a8aa5b2b3c90e3...
Exponent1: 0x8cb122099c9513ae...
Exponent2: 0x8a92c7071921cd30...
Coefficient: 0x722751305eafe9...
}
The line pubkey=0sAQOrW... of the private key contains a public key that should be stored in the other peer's configuration in this format:
: PUB 0sAQOrWlcwbAIdNSMhDt...
You can also specify from and to addresses for which the key is valid:
0.0.0.0/0 10.20.30.0/24 : PUB 0sAQOrWlcwbAIdNSMhDt...
SEE ALSO racoon.conf(5), racoon(8)HISTORY
plainrsa-gen was written by Michal Ludvig <michal@logix.cz> and first appeared in ipsec-tools 0.4.
BSD June 14, 2004 BSD
Hi all,
I am trying to write a program in C which will generate private and public keys using openssl RSA and use these for encryption and decryption. I am able to generate the keys successfully and write these to files. I am able to read the private key successfully. I can encrypt and decrypt... (1 Reply)
Hi all,
I have written a Java program to generate RSA public and private keys. I am writing the keys to a file and reading from it when required to encryption or decryption. I want to protect the private key file using a passphrase. Can anyone tell me how to do it? :(
Thanks. (2 Replies)
I want to automate the process of generating RSA keys. I want to remotley login to a linux machine from a windows maching without having to enter a password. For this I need to generate the RSA key pair. but I want to do this procedure on alot of linux machines. For which I was looking to automate... (2 Replies)
Hi all,
I needed a shell script for file transfering using public/private keys for authentication.
Could you please help me out on this?
A procedure to write a shell script is enough.
Thanks in advance.
Regards.
Vidya N (8 Replies)