PILOTFISH(8) BSD System Manager's Manual PILOTFISH(8)NAME
pilotfish -- Shark helper program for collecting symbol information from exited tasks.
SYNOPSIS
pilotfish
DESCRIPTION
pilotfish is used by Shark.app and shark(1) to gather symbol information from any exited tasks during profiling.
pilotfish is not intended to be invoked by the user, but automatically by Shark.app and shark(1).
SEE ALSO shark(1)BSD June 13, 2004 BSD
Check Out this Related Man Page
atlantis(6x) XScreenSaver manual atlantis(6x)NAME
atlantis - draw swimming sharks, whales, and dolphins.
SYNOPSIS
atlantis [-display host:display.screen] [-visual visual] [-window] [-root] [-whalespeed number] [-delay number] [-size number] [-count num-
ber] [-no-texture] [-gradient] [-wireframe] [-fps]
DESCRIPTION
This is xfishtank writ large: a GL animation of a number of sharks, dolphins, and whales. The swimming motions are great.
OPTIONS -visual visual
Specify which visual to use. Legal values are the name of a visual class, or the id number (decimal or hex) of a specific visual.
-window Draw on a newly-created window. This is the default.
-root Draw on the root window.
-whalespeed number
Whale Speed. 0 - 1000. Default: 250.
-cycles number
Shark Speed. Default: 100.
-size number
Shark Proximity. 100 - 10000. Default: 6000.
-count number
Number of Sharks. 0 - 20. Default: 4.
-texture | -no-texture
Whether to show shimmering water.
-gradient
Whether to draw a gradient on the background, making it darker at the bottom.
-wireframe
Render in wireframe instead of solid.
-fps Display the current frame rate, CPU load, and polygon count.
ENVIRONMENT
DISPLAY to get the default host and display number.
XENVIRONMENT
to get the name of a resource file that overrides the global resources stored in the RESOURCE_MANAGER property.
SEE ALSO X(1), xscreensaver(1)COPYRIGHT
Copyright (C) 2002 by Mark Kilgard. Permission to use, copy, modify, distribute, and sell this software and its documentation for any pur-
pose is hereby granted without fee, provided that the above copyright notice appear in all copies and that both that copyright notice and
this permission notice appear in supporting documentation. No representations are made about the suitability of this software for any pur-
pose. It is provided "as is" without express or implied warranty.
AUTHOR
Mark Kilgard.
X Version 11 5.15 (28-Sep-2011) atlantis(6x)
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)