path_helper(8) BSD System Manager's Manual path_helper(8)NAME
path_helper -- helper for constructing PATH environment variable
path_helper [-c | -s]
The path_helper utility reads the contents of the files in the directories /etc/paths.d and /etc/manpaths.d and appends their contents to the
PATH and MANPATH environment variables respectively. (The MANPATH environment variable will not be modified unless it is already set in the
Files in these directories should contain one path element per line.
Prior to reading these directories, default PATH and MANPATH values are obtained from the files /etc/paths and /etc/manpaths respectively.
-c Generate C-shell commands on stdout. This is the default if SHELL ends with "csh".
-s Generate Bourne shell commands on stdout. This is the default if SHELL does not end with "csh".
The path_helper utility should not be invoked directly. It is intended only for use by the shell profile.
Mac OS X March 15, 2007 Mac OS X
Check Out this Related Man Page
MAKEWHATIS(8) BSD System Manager's Manual MAKEWHATIS(8)NAME
makewhatis -- create whatis database
makewhatis [-a] [-i column] [-n name] [-o file] [-v] [-L] [directories ...]
The makewhatis utility collects the names and short descriptions from all the unformatted man pages in the directories and puts them into a
file used by the whatis(1) and apropos(1) commands. Directories may be separated by colons instead of spaces. If no directories are speci-
fied, the contents of the MANPATH environment variable will be used, or if that is not set, the default directory /usr/share/man will be pro-
The options are as follows:
-a Appends to the output file(s) instead of replacing them. The output will be sorted with duplicate lines removed, but may have
-i column Indents the description by column characters. The default value is 24.
-n name Uses name instead of whatis.
-o file Outputs all lines to the file instead of */man/whatis.
-v Makes makewhatis more verbose about what it is doing.
-L Process only localized subdirectories corresponding to the locale specified in the standard environment variables.
LC_ALL, LC_CTYPE, LANG
These variables control what subdirectories will be processed if the -L option is used.
MACHINE If set, its value is used to override the current machine type when searching machine specific subdirectories.
MANPATH Determines the set of directories to be processed if none are given on the command line.
/usr/share/man Default directory to process if the MANPATH environment variable is not set.
*/man/whatis The default output file.
The makewhatis utility exits 0 on success, and >0 if an error occurs.
SEE ALSO apropos(1), whatis(1)HISTORY
The makewhatis command appeared in FreeBSD 2.1.
The makewhatis program was originally written in Perl and was contributed by Wolfram Schneider. The current version of makewhatis was
rewritten in C by John Rochester.
BSD May 12, 2002 BSD
I have installed the Darwin Calendar Server on my Mac and got it working.
To start the server I open a Finder window on my mac and click the UNIX executable called RUN.
In order to start the server automatically on bootup I used LINGON to add a startup Daemon to call "RUN -d". When I reboot... (6 Replies)
I'm on my iMac, reading about bash from a book (learning the bash shell). It talks about these three files, but I can't find them. Am I to assume that these files don't have to be in and I can create them myself if I want to? (10 Replies)
Hi - I am trying to include the MSQ.exe that I have downloaded for the sake of learning. My current /.bash_profile file reads:
... (4 Replies)