nsnetworkd(8) BSD System Manager's Manual nsnetworkd(8)NAME
nsnetworkd -- The background NSURLSession daemon
SYNOPSIS
nsnetworkd
DESCRIPTION
nsnetworkd is a per-user daemon that performs tasks for background-configured NSURLSessions.
There are no configuration options to nsnetworkd. Users should not run nsnetworkd manually.
Mac OS X June 2, 2019 Mac OS X
Check Out this Related Man Page
vpnd(8) BSD System Manager's Manual vpnd(8)NAME
vpnd -- Mac OS X VPN service daemon
SYNOPSIS
vpnd [-d | -n | -x] [-i server_id]
vpnd [-h]
DESCRIPTION
vpnd allows external hosts to tunnel via L2TP over IPSec or via PPTP from an insecure external network (such as the Internet) into a "secure"
internal network, such as a corporate network. All traffic through the tunnel is encrypted to provide secure communications, with L2TP/IPSec
providing a higher level of security than PPTP.
vpnd listens for incoming connections, pairs each one with an available internal IP address, and passes the connection to pppd(8) with appro-
priate parameters. Parameters for vpnd are specified in a system configuration (plist) file in XML format. This file contains a dictionary
of configurations each identified by a key referred to as a server_id. Parameters include the tunneling protocol, IP addresses to be
assigned to clients, PPP parameters etc.
vpnd is launched for a particular configuration by using the -i option which takes the server_id to be run as an argument. vpnd can also be
run without the -i option. In this case it will check the configuration file for a special array which contains a list of configurations to
be run and will fork and exec a copy of vpnd for each server_id to be run. Running multiple vpnd processes simultaneously for a particular
protocol is not allowed.
vpnd will be launched during the boot process by a startup item if the field VPNSERVER is defined in /etc/hostconfig with the value -YES-.
Typically, in this case it will be launched without the -i option and will check the configuration file to determine which configuration(s)
are to be run.
vpnd logs items of interest to the system log. A different log path can be specified in the configuration file.
OPTIONS
The following options are available:
-d Do not move to background and print log strings to the terminal.
-h Print usage summary and exit.
-i Server_id in the plist file that defines the configuration to be run.
-n Do not move to background, print log information to the terminal, and quit after validating the argument list.
-x Do not move to background.
EXAMPLES
The default invocation,
vpnd
will read the list of configurations to run from the configuration file and launch them. This default configuration may be enabled at
startup by defining VPNSERVER to -YES-.
To specify a particular configuration to run use
vpnd -i server_id
FILES & FOLDERS
/usr/sbin/vpnd
/etc/hostconfig
/System/Library/StartupItems/NetworkExtensions
/Library/Preferences/SystemConfiguration/com.apple.RemoteAccessServers.plist
SEE ALSO pppd(8)vpnd(5)Mac OS X 21 August 2003 Mac OS X
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)