notifyd(8) BSD System Manager's Manual notifyd(8)NAME
notifyd -- notification server
notifyd [-d service_name] [-v] [-shm_pages npages] [-no_restart]
notifyd is the server for the Mac OS X notification system described in notify(3). The server is usually started automatically during system
startup, and is not run from the command line.
The -d option causes notifyd to run in a debugging mode. It registers its mach port with the given service name. It will stay attached to
the terminal and print verbose log messages to the terminal.
The -v option causes notifyd to produce verbose logging information.
The -shm_pages npages option sets the number of shared memory pages used for passive notification. The default is one page. If a value of
zero is specified, shared memory is disabled, and passive notifications are performed using IPC between the client and the server.
The -no_restart option causes notifyd to register as a non-restartable server with mach_init.
SEE ALSO notify(3).
Mac OS X March 24, 2003 Mac OS X
Check Out this Related Man Page
NOTIFYD(8) System Manager's Manual NOTIFYD(8)
notifyd - Cyrus notification server
notifyd [ -C config-file ] [ -U uses ] [ -T timeout ]
[ -D ]
Notifyd is a daemon started from cyrmaster(8) that handles notification requests on behalf of lmtpd(8). Notifyd accepts the request and
performs the notification using the method specified in the request.
Note that for notifyd to run properly you must set proto=udp in its cyrus.conf services entry. prefork=1 is also recommended.
Notifyd reads its configuration options out of the imapd.conf(5) file unless specified otherwise by -C. The notifysocket option is used to
specify the Unix domain socket to listen on for notifications.
OPTIONS -C config-file
Read configuration options from config-file.
The maximum number of times that the process should be used for new connections before shutting down. The default is 250.
The number of seconds that the process will wait for a new connection before shutting down. Note that a value of 0 (zero) will dis-
able the timeout. The default is 60.
-D Run external debugger specified in debug_command.
null Ignore the notification request.
log Log the notification to syslog (for testing).
mailto Email the notification. This method can ONLY be used in a Sieve 'notify' action as it requires a mailto: URL to be specified as an
zephyr Send the notification as a zephyrgram. If used in a Sieve 'notify' action, additional recipients can be specified as :options.
Send the notification via an external program. The path to the program is specified using the notify_external option in the config-
Default configuration file.
Cyrus Master process configuration file.
SEE ALSO imapd.conf(5), cyrus.conf, cyrmaster(8), lmtpd(8)CMU Project Cyrus NOTIFYD(8)
I am trying to write a bash script to emulate the rm command, I want to save all files I delete, a bit like the recycle bin in a windows OS. My script so far is below, I still need to amend a few things, once complete I plan to alias the script to rm and use it as a safe delete... (7 Replies)
fallowing code is for init script for dnotify service
# Dnotify startup script:-
# Init/rc scripts are bash scripts used to manage services like dnotify.
# Dnotify (directory notification) is a utility for monitoring filesystem... (0 Replies)
Friends i know mknod with -p option is used to create FIFO special file.:p
But i want to know some circumstance/scenario where these are used.:wall:
Actually i want to know where i can use it in real time.
Please advise.:) (3 Replies)
I am thinking of developing an app' for Android mobile devices...
Two questions here:-
1) Does anyone _develop_ for the Android _mobile_ platform?
If so do you use OSX 10.7.5 or greater as your _development_platform_?
2) I know ********* is gonna say that the Android terminal/shell is... (13 Replies)
I have an Kaon router wich runs "Linux version 3.10.24-svn1480 (jskim@jake-205) (gcc version 4.4.7 (Realtek MSDK-4.4.7 Build 1459".
The problem I have it is that its firmware is in early stages and has alot of things messed up.
Wake on lan doesn't work without arp binding and that can... (23 Replies)