Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

mount_fdesc(8) [osx man page]

MOUNT_FDESC(8)						    BSD System Manager's Manual 					    MOUNT_FDESC(8)

NAME
mount_fdesc -- mount the file-descriptor file system SYNOPSIS
mount_fdesc [-o options] fdesc mount_point DESCRIPTION
The mount_fdesc command attaches an instance of the per-process file descriptor namespace to the global filesystem namespace. The conven- tional mount point is /dev and the filesystem should be union mounted in order to augment, rather than replace, the existing entries in /dev. This command is normally executed by mount(8) at boot time. The options are as follows: -o Options are specified with a -o flag followed by a comma separated string of options. See the mount(8) man page for possible options and their meanings. The contents of the mount point are fd, stderr, stdin, stdout and tty. fd is a directory whose contents appear as a list of numbered files which correspond to the open files of the process reading the directory. The files /dev/fd/0 through /dev/fd/# refer to file descriptors which can be accessed through the file system. If the file descriptor is open and the mode the file is being opened with is a subset of the mode of the existing descriptor, the call: fd = open("/dev/fd/0", mode); and the call: fd = fcntl(0, F_DUPFD, 0); are equivalent. The files /dev/stdin, /dev/stdout and /dev/stderr appear as symlinks to the relevant entry in the /dev/fd sub-directory. Opening them is equivalent to the following calls: fd = fcntl(STDIN_FILENO, F_DUPFD, 0); fd = fcntl(STDOUT_FILENO, F_DUPFD, 0); fd = fcntl(STDERR_FILENO, F_DUPFD, 0); Flags to the open(2) call other than O_RDONLY, O_WRONLY and O_RDWR are ignored. The /dev/tty entry is an indirect reference to the current process's controlling terminal. It appears as a named pipe (FIFO) but behaves in exactly the same way as the real controlling terminal device. FILES
/dev/fd/# /dev/stdin /dev/stdout /dev/stderr /dev/tty SEE ALSO
mount(2), unmount(2), tty(4), fstab(5), mount(8) CAVEATS
No ~. and .. entries appear when listing the contents of the /dev/fd directory. This makes sense in the context of this filesystem, but is inconsistent with usual filesystem conventions. However, it is still possible to refer to both ~. and .. in a pathname. This filesystem may not be NFS-exported. HISTORY
The mount_fdesc utility first appeared in 4.4BSD. 4.4BSD March 27, 1994 4.4BSD

Check Out this Related Man Page

MOUNT(8)						    BSD System Manager's Manual 						  MOUNT(8)

NAME
mount -- mount file systems SYNOPSIS
mount [-adfruvw] [-t ufs | lfs | external_type] mount [-dfruvw] special | node mount [-dfruvw] [-o options] [-t ufs | lfs | external_type] special node DESCRIPTION
The mount command calls the mount(2) system call to prepare and graft a special device or the remote node (rhost:path) on to the file system tree at the point node. If either special or node are not provided, the appropriate information is taken from the fstab(5) file. The system maintains a list of currently mounted file systems. If no arguments are given to mount, this list is printed. The options are as follows: -a All the filesystems described in fstab(5) are mounted. Exceptions are those marked as ``noauto'' or are excluded by the -t flag (see below). -d Causes everything to be done except for the actual system call. This option is useful in conjunction with the -v flag to determine what the mount command is trying to do. -f Forces the revocation of write access when trying to downgrade a filesystem mount status from read-write to read-only. -o Options are specified with a -o flag followed by a comma separated string of options. The following options are available: async All I/O to the file system should be done asynchronously. This can be somewhat dangerous with respect to losing data when faced with system crashes and power outages. This is also the default. It can be avoided with the noasync option. force The same as -f; forces the revocation of write access when trying to downgrade a filesystem mount status from read-write to read-only. noasync This filesystem should not force all I/O to be written asynchronously. noauto This filesystem should be skipped when mount is run with the -a flag. nodev Do not interpret character or block special devices on the file system. This option is useful for a server that has file systems containing special devices for architectures other than its own. noexec Do not allow execution of any binaries on the mounted file system. This option is useful for a server that has file systems containing binaries for architectures other than its own. nosuid Do not allow set-user-identifier or set-group-identifier bits to take effect. rdonly The same as -r; mount the file system read-only (even the super-user may not write it). sync All I/O to the file system should be done synchronously. update The same as -u; indicate that the status of an already mounted file system should be changed. union Causes the namespace at the mount point to appear as the union of the mounted filesystem root and the existing directory. Lookups will be done in the mounted filesystem first. If those operations fail due to a non-existent file the underlying directory is then accessed. All creates are done in the mounted filesystem. Any additional options specific to a filesystem type that is not one of the internally known types (see the -t option) may be passed as a comma separated list; these options are distinguished by a leading ``-'' (dash). Options that take a value are specified using the syntax -option=value. For example, the mount command: mount -t hfs -o nosuid,-w,-m=755 /dev/disk2s9 /tmp causes mount to execute the equivalent of: /sbin/mount_hfs -o nosuid -w -m 755 /dev/disk2s9 /tmp -r The file system is to be mounted read-only. Mount the file system read-only (even the super-user may not write it). The same as the ``rdonly'' argument to the -o option. -t ufs | lfs | external type The argument following the -t is used to indicate the file system type. The type ufs is the default. The -t option can be used to indicate that the actions should only be taken on filesystems of the specified type. More than one type may be specified in a comma separated list. The list of filesystem types can be prefixed with ``no'' to specify the filesystem types for which action should not be taken. For example, the mount command: mount -a -t nonfs,hfs mounts all filesystems except those of type NFS and HFS. If the type is not one of the internally known types, mount will attempt to execute a program in /sbin/mount_XXX where XXX is replaced by the type name. For example, nfs filesystems are mounted by the program /sbin/mount_nfs. -u The -u flag indicates that the status of an already mounted file system should be changed. Any of the options discussed above (the -o option) may be changed; also a file system can be changed from read-only to read-write or vice versa. An attempt to change from read-write to read-only will fail if any files on the filesystem are currently open for writing unless the -f flag is also specified. The set of options is determined by first extracting the options for the file system from the fstab table, then applying any options specified by the -o argument, and finally applying the -r or -w option. -v Verbose mode. -w The file system object is to be read and write. The options specific to NFS filesystems are described in the mount_nfs(8) manual page. FILES
/etc/fstab file system table SEE ALSO
mount(2), fstab(5), mount_afp(8), mount_cd9660(8), mount_cddafs(8), mount_devfs(8), mount_fdesc(8), mount_hfs(8), mount_msdos(8), mount_nfs(8), mount_smbfs(8), mount_synthfs(8), mount_udf(8), mount_volfs(8), mount_webdav(8), umount(8) BUGS
It is possible for a corrupted file system to cause a crash. HISTORY
A mount command appeared in Version 6 AT&T UNIX. 4th Berkeley Distribution June 16, 1994 4th Berkeley Distribution
Man Page