MAKEKEY(8) BSD System Manager's Manual MAKEKEY(8)NAME
makekey -- make encrypted keys or passwords
Makekey encrypts a key and salt which it reads from the standard input, writing the result to the standard output. The key and salt values
are expected to be ten and two bytes, respectively, in length. See crypt(3) for more information on what characters the key and salt can
contain and how the encrypted value is calculated.
SEE ALSO crypt(1), login(1), crypt(3)HISTORY
A makekey command appeared in Version 7 AT&T UNIX.
BSD December 11, 1993 BSD
Check Out this Related Man Page
makekey(1) General Commands Manual makekey(1)NAME
makekey - generate encryption key
improves the usefulness of encryption schemes depending on a key by increasing the amount of time required to search the key space. It
reads 10 bytes from its standard input and writes 13 bytes on its standard output. The output depends on the input in a way intended to be
difficult to compute (i.e., to require a substantial fraction of a second).
The first eight input bytes (the input key) can be arbitrary ASCII characters. The last two (the salt) are best chosen from the set of
digits, and uppercase and lowercase letters. The salt characters are repeated as the first two characters of the output. The remaining 11
output characters are chosen from the same set as the salt and constitute the output key.
The transformation performed is essentially the following: the salt is used to select one of 4,096 cryptographic machines all based on the
National Bureau of Standards DES algorithm, but broken in 4,096 different ways. Using the input key as key, a constant string is fed into
the machine and recirculated a number of times. The 64 bits that come out are distributed into the 66 output key bits in the result.
is intended for programs that perform encryption (e.g., ed(1) and crypt(1)). Usually, its input and output will be pipes.
SEE ALSO crypt(1), ed(1), passwd(4).
I want to know how to find a node path of a unix command. I tried the command which, but it didn't find the "makekey" command node path... Are there any tricks about the "which" command? Should I use this command on a special level of directories? Moreover, I am accessing in remote the computers of... (5 Replies)
I wonder I had have a look to the cc compile options but I could be missing one but basically I'm compliling a c program where I will storing a command to connect to a database and also userid and password. The issue is that after the module is generated using a command like strings I... (14 Replies)
I am new to unix,and need your advice on the below.
I am using aix5.3 and have installed make-3.82 on the server.
I need to use gmake for configuring and installing a package ,but it is giving error at the below
... (7 Replies)
I tried googling about it and I couldn't really find a solid answer. Why is the compiler missing the exception class when it seems to be a standard class?
The code is here:
using... (6 Replies)
I am unable to set the password remotely. I am using the script as below:
ep=`echo "$p" | /usr/lbin/makekey`
ssh -t $i "/usr/local/bin/sudo useradd -c "$user_c" -m -d /home/$user_id -s /bin/ksh $user_id; /usr/local/bin/sudo /usr/sam/lbin/usermod.sam -F -p $ep $user_id"
The... (0 Replies)
I have created a script to generate a random password on Linux/Solaris, but I simply cannot use it on my AIX VMs since Bash isn't installed on them.
I need a password that is randomly created with the following... (12 Replies)