LOGKEXTLOADSD(8) BSD System Manager's Manual LOGKEXTLOADSD(8)NAME
logkextloadsd -- logs information about the kexts that get loaded
SYNOPSIS
logkextloadsd
DESCRIPTION
The logkextloadsd command should not be run directly.
SEE ALSO BSD Nov 12, 2012 BSD
Check Out this Related Man Page
KEXTSTAT(8) BSD System Manager's Manual KEXTSTAT(8)NAME
kextstat -- display status of loaded kernel extensions (kexts)
SYNOPSIS
kextstat [-a] [-h] [-k] [-l] [-b identifier] ...
DESCRIPTION
The kextstat utility displays the status of any kexts currently loaded in the kernel. The following information is shown for each loaded
kext:
Index The load index of the kext (used to track linkage references). Gaps in the list indicate kexts that have been unloaded.
Refs The number of references to this kext by others. If nonzero, the kext cannot be unloaded.
Address The address in kernel space where the kext has been loaded.
Size The number of bytes of kernel memory that the kext occupies. If this is zero, the kext is a built-in part of the kernel that has a
record as a kext for resolving dependencies among kexts.
Wired The number of wired bytes of kernel memory that the kext occupies.
Architecture (if the -a option is used)
The architecture of the kext.
Name The CFBundleIdentifier of the kext.
(Version)
The CFBundleVersion of the kext.
<Linked Against>
The index numbers of all other kexts that this kext has a reference to.
OPTIONS
These options are available:
-a, -arch
Print the architecture of the kext.
-b identifier, -bundle-id identifier
Display the status of only the kext with the given bundle identifier. This option trumps the -no-kernel option; if both are given
and a kernel component is specified, its information is shown.
-h, -help
Print a help message describing each option flag and exit with a success result, regardless of any other options on the command
line.
-k, -no-kernel
Don't show information for built-in components of the kernel.
-l, -list-only
Print the list of loaded kexts only and omit the header (useful for running output through text-analysis tools).
-s, -sort
Sort the list by load address.
DIAGNOSTICS
The kextstat utility exits with a status of 0 on success and with a nonzero status if an error occurs.
SEE ALSO kextcache(8), kextd(8), kextload(8), kextunload(8), kextutil(8)Darwin March 13, 2014 Darwin
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)