ip6(8) BSD System Manager's Manual ip6(8)NAME
ip6 -- Enable or disable IPv6 on active interfaces
ip6 [-ax] [-ud -interface]
ip6 can be used to start up or shut down IPv6 on active interfaces. When IPv6 is enabled on an interface the protocol is attached to the
interface, at which point the default settings in the kernel allow it to acquire a link-local address and accept router advertisements. Dis-
abling detaches the protocol from the interface.
Possible options are:
-a Start IPv6 on all interfaces.
-x Stop IPv6 on all interfaces.
Start IPv6 on interface.
Stop IPv6 on interface.
You need support for IPv6 in your kernel. This is provided beginning with Darwin Kernel Version 6.0.
The default IPv6 configuration for an interface assigns a link-local address to it and sets the interface to receive router advertisements.
No further configuration is necessary for basic functionality. However, various settings can be modified by using sysctl. Pp
SEE ALSO stf(4), IPv6 Documentation at http://www.netbsd.org/Documentation/network/ipv6/, RFC 3068.
BSD May 23, 2002 BSD
Check Out this Related Man Page
FAITH(4) BSD Kernel Interfaces Manual FAITH(4)NAME
faith -- IPv6-to-IPv4 TCP relay capturing interface
The faith interface captures IPv6 TCP traffic, for implementing userland IPv6-to-IPv4 TCP relay like faithd(8).
Each faith interface is created at runtime using interface cloning. This is most easily done with the ifconfig(8) create command or using
the cloned_interfaces variable in rc.conf(5).
Special action will be taken when IPv6 TCP traffic is seen on a router, and the default routing table suggests to route it to the faith
interface. In this case, the packet will be accepted by the router, regardless of the list of IPv6 interface addresses assigned to the
router. The packet will be captured by an IPv6 TCP socket, if it has the IN6P_FAITH flag turned on and matching address/port pairs. As a
result, faith will let you capture IPv6 TCP traffic to some specific destination addresses. Userland programs, such as faithd(8) can use
this behavior to relay IPv6 TCP traffic to IPv4 TCP traffic. The program can accept some specific IPv6 TCP traffic, perform getsockname(2)
to get the IPv6 destination address specified by the client, and perform application-specific address mapping to relay IPv6 TCP to IPv4 TCP.
The IN6P_FAITH flag on a IPv6 TCP socket can be set by using setsockopt(2), with level IPPROTO_IPV6 and optname IPv6_FAITH.
To handle error reports by ICMPv6, some ICMPv6 packets routed to an faith interface will be delivered to IPv6 TCP, as well.
To understand how faith can be used, take a look at the source code of faithd(8).
As the faith interface implements potentially dangerous operations, great care must be taken when configuring it. To avoid possible misuse,
the sysctl(8) variable net.inet6.ip6.keepfaith must be set to 1 prior to using the interface. When net.inet6.ip6.keepfaith is 0, no packets
will be captured by the faith interface.
The faith interface is intended to be used on routers, not on hosts.
SEE ALSO inet(4), inet6(4), faithd(8)
Jun-ichiro itojun Hagino and Kazu Yamamoto, An IPv6-to-IPv4 transport relay translator, RFC3142.
The FAITH IPv6-to-IPv4 TCP relay translator first appeared in the WIDE hydrangea IPv6 stack.
BSD January 23, 2012 BSD