HTTXT2DBM(8) BSD System Manager's Manual HTTXT2DBM(8)NAME
httxt2dbm -- Generate dbm files for use with RewriteMap
httxt2dbm [-v] [-f DBM_TYPE] -i SOURCE_TXT -o OUTPUT_DBM
DESCRIPTION -v More verbose output.
-f Specify the DBM type to be used for the output. If not specified, will use the APR default. Available types are:
GDBM GDBM files
SDBM SDBM files
DB Berkeley DB files
NDBM NDBM files
default default DBM type
-i Input file from which the dbm is to be created. This file should be formatted with one record per line, of the form: ``key value''.
See the documentation for RewriteMap for further details of this file's format and meaning.
-o Name of the output dbm files.
httxt2dbm -i rewritemap.txt -o rewritemap.dbm
httxt2dbm -f SBDM -i rewritemap.txt -o rewritemap.dbm
SEE ALSO httpd(8)BSD October 21, 2008 BSD
Check Out this Related Man Page
DBMMANAGE(1) dbmmanage DBMMANAGE(1)NAME
dbmmanage - Manage user authentication files in DBM format
dbmmanage [ encoding ] filename add|adduser|check|delete|update username [ encpasswd [ group[,group...] [ comment ] ] ]
dbmmanage filename view [ username ]
dbmmanage filename import
dbmmanage is used to create and update the DBM format files used to store usernames and password for basic authentication of HTTP users via
mod_authn_dbm. Resources available from the Apache HTTP server can be restricted to just the users listed in the files created by dbmman-
age. This program can only be used when the usernames are stored in a DBM file. To use a flat-file database see htpasswd.
Another tool to maintain a DBM password database is htdbm.
This manual page only lists the command line arguments. For details of the directives necessary to configure user authentication in httpd
see the httpd manual, which is part of the Apache distribution or can be found at http://httpd.apache.org/.
The filename of the DBM format file. Usually without the extension .db, .pag, or .dir.
The user for which the operations are performed. The username may not contain a colon (:).
This is the already encrypted password to use for the update and add commands. You may use a hyphen (-) if you want to get prompted
for the password, but fill in the fields afterwards. Additionally when using the update command, a period (.) keeps the original
group A group, which the user is member of. A groupname may not contain a colon (:). You may use a hyphen (-) if you don't want to assign
the user to a group, but fill in the comment field. Additionally when using the update command, a period (.) keeps the original
This is the place for your opaque comments about the user, like realname, mailaddress or such things. The server will ignore this
-d crypt encryption (default, except on Win32, Netware)
-m MD5 encryption (default on Win32, Netware)
-s SHA1 encryption
-p plaintext (not recommended)
add Adds an entry for username to filename using the encrypted password encpasswd. dbmmanage passwords.dat add rbowen foKntnEF3KSXA
Asks for a password and then adds an entry for username to filename. dbmmanage passwords.dat adduser krietz
check Asks for a password and then checks if username is in filename and if it's password matches the specified one. dbmmanage pass-
words.dat check rbowen
delete Deletes the username entry from filename. dbmmanage passwords.dat delete rbowen
import Reads username:password entries (one per line) from STDIN and adds them to filename. The passwords already have to be crypted.
update Same as the adduser command, except that it makes sure username already exists in filename. dbmmanage passwords.dat update rbowen
view Just displays the contents of the DBM file. If you specify a username, it displays the particular record only. dbmmanage pass-
One should be aware that there are a number of different DBM file formats in existence, and with all likelihood, libraries for more than
one format may exist on your system. The three primary examples are SDBM, NDBM, the GNU project's GDBM, and Berkeley DB 2. Unfortunately,
all these libraries use different file formats, and you must make sure that the file format used by filename is the same format that dbm-
manage expects to see. dbmmanage currently has no way of determining what type of DBM file it is looking at. If used against the wrong for-
mat, will simply return nothing, or may create a different DBM file with a different name, or at worst, it may corrupt the DBM file if you
were attempting to write to it.
dbmmanage has a list of DBM format preferences, defined by the @AnyDBM::ISA array near the beginning of the program. Since we prefer the
Berkeley DB 2 file format, the order in which dbmmanage will look for system libraries is Berkeley DB 2, then NDBM, then GDBM and then
SDBM. The first library found will be the library dbmmanage will attempt to use for all DBM file transactions. This ordering is slightly
different than the standard @AnyDBM::ISA ordering in Perl, as well as the ordering used by the simple dbmopen() call in Perl, so if you use
any other utilities to manage your DBM files, they must also follow this preference ordering. Similar care must be taken if using programs
in other languages, like C, to access these files.
One can usually use the file program supplied with most Unix systems to see what format a DBM file is in.
Apache HTTP Server 2018-07-06 DBMMANAGE(1)