fontd(8) BSD System Manager's Manual fontd(8)NAME
fontd -- Mac OS X system font registration manager
fontd is a system daemon which makes fonts available to the system.
There are no configuration options to fontd. Users should not run fontd manually.
SEE ALSO atsutil(8)HISTORY
The fontd daemon first appeared in MacOS X 10.6 replacing the ATSServer daemon.
Mac OS June 2, 2019 Mac OS
Check Out this Related Man Page
atsutil(8) BSD System Manager's Manual atsutil(8)NAME
atsutil -- font registration system utility
atsutil autoactivation [-DdeaRh] [path]
atsutil databases [-remove | -removeUser]
atsutil fontprotection [-on | -off] [-get] [-files] [-fonts]
atsutil server [-ping | -shutdown]
atsutil tool controls some aspects of the font registration system. It may be used to modify font auto activation settings, font protection
settings, remove font registration databases and caches, or restart the font registration daemon.
autoactivation modifies font auto activation settings globally or for a specific application.
databases will remove fontd System or User databases along with any cache files. Removing databases may cause the loss of font registration
state: fonts activated outside the standard font directories, font faces disabled, and font libraries. New databases will be regenerated from
fonts installed the standard font directories after the user logs out, restarts, or the fontd server is restarted.
fontprotection overrides System font protection settings.
server queries the status of fontd or shutdowns the fontd. Shutting down the fontd will spawn a new fontd. Shutting down the server is NOT
recommended and will likely lead to misrendered text or application crashes.
autoactivation [-DdeaRh] [path]
-D set font auto activation setting to default.
-d is specified, then set font auto activation setting to disabled.
-e is specified, then set font auto activation setting to enabled.
-a is specified, then set font auto activation setting to ask.
-R is specified, then reset font auto activation setting to default.
-h is specified, then display help information.
-path with options is specified, then set font auto activation setting locally for application. Otherwise, setting is global in scope.
Note, path without options will return current font auto activation setting for application.
databases [-remove | -removeUser]
-remove remove fontd databases for active user and system (used when no one is logged in and some background processes).
-removeUser remove fontd databases for the active user only.
fontprotection [-on | -off] [-get] [-files] [-fonts]
-on enable System font protection.
-off disable System font protection.
-get return System font protection setting.
-files prints list of protected font files.
-fonts prints list of protected font faces (Postscript names).
server [-ping | -shutdown]
-ping query running fontd.
-shutdown shutdown fontd and spawn a new fontd. NOTE: this action is not recommended. See above.
SEE ALSO fontd(8)HISTORY
atsutil first appeared in MacOS X 10.5.
Mac OS June 2, 2019 Mac OS
I have tried to start X windonws using the startx command. It fails.
the error message I receive is:
warning: 'fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/font/local". Entry deleted from font path
(Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/local)
xf86Openconsole: KDEABOP... (2 Replies)
Hi to all,
I have copied some true type fonts to my /usr/openwin/lib/X11/fonts/TrueType directory. I need to get the fonts.dir file updated. I have tried using the mkfontdir command but the file does not get updated with my new fonts. Can someone please help me as I have struggled with this... (3 Replies)
Hello Everyone :) ,
I have this printer installed on the network which is an HP 1160.
When sending a print job to the printer from SCO Unix 7.1 it prints one line of text and the rest of it comes up with blank pages.
I have tried deleting the printer and recreating it; but I am getting... (6 Replies)
I want to install some fonts from my unix box (Tru64) to linux box (RHEL4). I know what all steps are required, like
> xset fp rehash
The problem is i am not able to find out which font is actually required from unix box to be installed on linux box. Is... (1 Reply)
Might anyone know how to make a nbsp (160|0xA0) character? I am using a Dell Latitude D620 running Windows XP and then starting Exceed 9.0 defaulting to native window emulation for my X (us.kbf keymapping) (Latin-1 symbol set I believe) and calling an xterm (fontdefault, whatever that might be)... (1 Reply)
We have an app that prints PDF files but some of the required TrueType fonts are missing on our AIX box. Does AIX support TrueType fonts? How can I install the following fonts?:
OCR A Extended (OCRAEXT.TTF)
Courier New (cour.ttf)
I have tried copying those fonts from my Windows box into... (4 Replies)
I'm trying to write a simple if statement in TCSH and I honestly can't figure out what I'm doing wrong. I've played around with all sorts of permutations of syntax.
if ($DESKTOP_SESSION == "kde") then
replace "forceFontDPI=0" "forceFontDPI=96" --... (0 Replies)
Look this very good rendering on Slackware 14.2
in my opinion is near perfect.
Now look the same page on Fedora 30
In my opinion the fonts on Fedora are too small and difficult to read, I prefer the fat fonts of... (20 Replies)
Guys: I have a customer using the 'pdftotext' utility under Linux. PDFs are received via email, converted to text, etc. and it has worked nicely for years. They received a PDF from a customer and the utility will not read it. The text file is created but it's either empty or has 1-2 bytes of... (23 Replies)