filecoordinationd(8) BSD System Manager's Manual filecoordinationd(8)NAME
filecoordinationd -- system-wide file access coordination
SYNOPSIS
filecoordinationd
DESCRIPTION
filecoordinationd is used by the Foundation framework's NSFileCoordinator class to coordinate access to files by multiple processes, and to
message registered NSFilePresenters.
There are no configuration options to filecoordinationd. Users should not run filecoordinationd manually.
Mac OS X Mar 15, 2011 Mac OS X
Check Out this Related Man Page
SW_VERS(1) BSD General Commands Manual SW_VERS(1)NAME
sw_vers -- print Mac OS X operating system version information
SYNOPSIS
sw_vers
sw_vers -productName
sw_vers -productVersion
sw_vers -buildVersion
DESCRIPTION
sw_vers prints version information about the Mac OS X or Mac OS X Server operating system running on the local machine.
When executed with no options sw_vers prints a short list of version properties:
% sw_vers
ProductName: Mac OS X
ProductVersion: 10.3
BuildVersion: 7A100
The ProductName property provides the name of the operating system release (typically either "Mac OS X" or "Mac OS X Server"). The
ProductVersion property defines the version of the operating system release (for example, "10.2.4" or "10.3"). The BuildVersion property
provides the specific revision of the operating system as generated by the Mac OS X build system.
OPTIONS
The output of sw_vers can be refined by the following options.
-productName Print just the value of the ProductName property.
-productVersion Print just the value of the ProductVersion property.
-buildVersion Print just the value of the BuildVersion property.
EXAMPLES
% sw_vers -productName
Mac OS X
% sw_vers -productVersion
10.3
% sw_vers -buildVersion
7A100
FILES
/System/Library/CoreServices/SystemVersion.plist
/System/Library/CoreServices/ServerVersion.plist
Mac OS X March 10, 2003 Mac OS X
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)