CHECKGID(8) BSD System Manager's Manual CHECKGID(8)NAME
checkgid -- validate group identifiers
checkgid group ...
Given one or more group identifers on the command line (e.g., "httpd" or "#-1"), figure out whether they'll be valid for the server to use at
If a groupname isn't found, or we can't setgid() to it, return -1. If all groups are valid, return 0.
This may need to be run as the superuser for the setgid() to succeed; running it as any other user may result in a false negative.
SEE ALSO httpd(8)BSD October 21, 2008 BSD
Check Out this Related Man Page
DM(8) BSD System Manager's Manual DM(8)NAME
dm -- dungeon master
ln -s dm game
dm is a program used to regulate game playing. dm expects to be invoked with the name of a game that a user wishes to play. This is done by
creating symbolic links to dm, in the directory /usr/games for all of the regulated games. The actual binaries for these games should be
placed in a ``hidden'' directory, /usr/lib/games/dm, that may only be accessed by the dm program. dm determines if the requested game is
available and, if so, runs it. The file /etc/dm.conf controls the conditions under which games may be run.
The file /etc/nogames may be used to ``turn off'' game playing. If the file exists, no game playing is allowed; the contents of the file
will be displayed to any user requesting a game.
/etc/dm.conf configuration file
/etc/nogames turns off game playing
/usr/lib/games/dm directory of ``real'' binaries
/var/games/games.log game logging file
SEE ALSO dm.conf(5)HISTORY
The dm command appeared in 4.3BSD-Tahoe.
Two issues result from dm running the games setgid ``games''. First, all games that allow users to run UNIX commands should carefully set
both the real and effective group ids immediately before executing those commands. Probably more important is that dm never be setgid any-
thing but ``games'' so that compromising a game will result only in the user's ability to play games at will. Secondly, games which previ-
ously had no reason to run setgid and which accessed user files may have to be modified.
BSD May 31, 1993 BSD
I want to build a little website on a Sun Blade 100 running Solaris 10.
I just went out to apache.org and downloaded Unix Source: httpd-2.2.8.tar.gz
After unpacking the tarball, I CD'd into the subdirectory and ran the configure utility. Of course, it crapped out. I see that it is... (17 Replies)
I'm trying to install apache 2.2.14 on Solaris with Openssl. I'm using following configure options:
./configure --prefix=/usr/local/apache2 --enable-ssl --enable-module=so --enable-proxy=shared --enable-proxy-http=shared --enable-proxy-ajp=shared --with-ssl=/usr/local/openssl
... (3 Replies)
I have installed apache2 on Solaris machine with the binary. So i dont want to install the same binary across all the systems but only want to copy the lib files and the files which have been updated in this installation process.
So in order to get those lib files and then prepare a tar package... (5 Replies)
Generally we will run to install, configure apache 2.x on Solaris machine, but dont want to follow these on the remaining machines.
I want to build the apache binary centrally, so that i can untar the tar file on remaining machines. Please suggest on how to prepare this file and when i... (12 Replies)
hey guys ,
after migrate our AIX server from 6.1 to 7.1 , we insalled c compilator with rpm files
Server:root:/ > rpm -qa | grep gcc
but whene we proceed to compile a c programm we have this error
exec(): 0509-036... (17 Replies)