Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

environ(7) [osx man page]

ENVIRON(7)					       BSD Miscellaneous Information Manual						ENVIRON(7)

NAME
environ -- user environment SYNOPSIS
extern char **environ; DESCRIPTION
An array of strings called the environment is made available by execve(2) when a process begins. By convention these strings have the form ``name=value''. The following names are used by various commands: BLOCKSIZE The size of the block units used by several commands, most notably df(1), du(1) and ls(1). BLOCKSIZE may be specified in units of a byte by specifying a number, in units of a kilobyte by specifying a number followed by ``K'' or ``k'', in units of a megabyte by specifying a number followed by ``M'' or ``m'' and in units of a gigabyte by specifying a number followed by ``G'' or ``g''. Sizes less than 512 bytes or greater than a gigabyte are ignored. EXINIT A startup list of commands read by ex(1) and vi(1). HOME A user's login directory, set by login(1) from the password file passwd(5). PATH The sequence of directories, separated by colons, searched by csh(1), sh(1), system(3), execvp(3), etc, when looking for an exe- cutable file. PATH is set to ``/usr/bin:/bin'' initially by login(1). PRINTER The name of the default printer to be used by lpr(1), lpq(1), and lprm(1). SHELL The full pathname of the user's login shell. TERM The kind of terminal for which output is to be prepared. This information is used by commands, such as nroff(1) which may exploit special terminal capabilities. See termcap(3) and terminfo(5). TMPDIR The directory in which to store temporary files. Most applications use either ``/tmp'' or ``/var/tmp''. Setting this variable will make them use another directory. TZ The timezone to use when displaying dates. The normal format is a pathname relative to ``/usr/share/zoneinfo''. For example, the command ``env TZ=US/Pacific date'' displays the current time in California. See tzset(3) for more information. LOGNAME The login name of the user. USER Deprecated synonym of LOGNAME (for backwards compatibility). Further names may be placed in the environment by the export command and name=value arguments in sh(1), or by the setenv command if you use csh(1). It is unwise to change certain sh(1) variables that are frequently exported by .profile files, such as MAIL, PS1, PS2, and IFS, unless you know what you are doing. PROGRAMMING
Programs can query and modify the environment, using the environment routines getenv(3), putenv(3), setenv(3) and unsetenv(3). Direct access can be made through the global variable environ, though it is recommended that changes to the enviroment still be made through the environ- ment routines. Shared libraries and bundles don't have direct access to environ, which is only available to the loader ld(1) when a complete program is being linked. The environment routines can still be used, but if direct access to environ is needed, the _NSGetEnviron() routine, defined in <crt_externs.h>, can be used to retrieve the address of environ at runtime. SEE ALSO
csh(1), ex(1), login(1), sh(1), getenv(3), putenv(3), setenv(3), unsetenv(3), execve(2), execle(3), system(3), termcap(3), terminfo(5) HISTORY
The environ manual page appeared in 4.2BSD. 4.2 Berkeley Distribution April 19, 1994 4.2 Berkeley Distribution

Check Out this Related Man Page

ENVIRON(7)						     Linux Programmer's Manual							ENVIRON(7)

NAME
environ - user environment SYNOPSIS
extern char **environ; DESCRIPTION
The variable environ points to an array of pointers to strings called the "environment". The last pointer in this array has the value NULL. (This variable must be declared in the user program, but is declared in the header file <unistd.h> in case the header files came from libc4 or libc5, and in case they came from glibc and _GNU_SOURCE was defined.) This array of strings is made available to the process by the exec(3) call that started the process. By convention the strings in environ have the form "name=value". Common examples are: USER The name of the logged-in user (used by some BSD-derived programs). LOGNAME The name of the logged-in user (used by some System-V derived programs). HOME A user's login directory, set by login(1) from the password file passwd(5). LANG The name of a locale to use for locale categories when not overridden by LC_ALL or more specific environment variables like LC_COL- LATE, LC_CTYPE, LC_MESSAGES, LC_MONETARY, LC_NUMERIC, LC_TIME, cf. locale(5). PATH The sequence of directory prefixes that sh(1) and many other programs apply in searching for a file known by an incomplete pathname. The prefixes are separated by ':'. (Similarly one has CDPATH used by some shells to find the target of a change directory command, MANPATH used by man(1) to find manual pages, etc.) PWD The current working directory. Set by some shells. SHELL The pathname of the user's login shell. TERM The terminal type for which output is to be prepared. PAGER The user's preferred utility to display text files. EDITOR/VISUAL The user's preferred utility to edit text files. Further names may be placed in the environment by the export command and "name=value" in sh(1), or by the setenv command if you use csh(1). Arguments may also be placed in the environment at the point of an exec(3). A C program can manipulate its environment using the functions getenv(3), putenv(3), setenv(3), and unsetenv(3). Note that the behavior of many programs and library routines is influenced by the presence or value of certain environment variables. A random collection: The variables LANG, LANGUAGE, NLSPATH, LOCPATH, LC_ALL, LC_MESSAGES, etc. influence locale handling, cf. locale(5). TMPDIR influences the path prefix of names created by tmpnam(3) and other routines, the temporary directory used by sort(1) and other pro- grams, etc. LD_LIBRARY_PATH, LD_PRELOAD and other LD_* variables influence the behavior of the dynamic loader/linker. POSIXLY_CORRECT makes certain programs and library routines follow the prescriptions of POSIX. The behavior of malloc(3) is influenced by MALLOC_* variables. The variable HOSTALIASES gives the name of a file containing aliases to be used with gethostbyname(3). TZ and TZDIR give timezone information used by tzset(3) and through that by functions like ctime(3), localtime(3), mktime(3), strftime(3). See also tzselect(8). TERMCAP gives information on how to address a given terminal (or gives the name of a file containing such information). COLUMNS and LINES tell applications about the window size, possibly overriding the actual size. PRINTER or LPDEST may specify the desired printer to use. See lpr(1). Etc. BUGS
Clearly there is a security risk here. Many a system command has been tricked into mischief by a user who specified unusual values for IFS or LD_LIBRARY_PATH. There is also the risk of name space pollution. Programs like make and autoconf allow overriding of default utility names from the envi- ronment with similarly named variables in all caps. Thus one uses CC to select the desired C compiler (and similarly MAKE, AR, AS, FC, LD, LEX, RM, YACC, etc.). However, in some traditional uses such an environment variable gives options for the program instead of a pathname. Thus, one has MORE, LESS, and GZIP. Such usage is considered mistaken, and to be avoided in new programs. The authors of gzip should con- sider renaming their option to GZIP_OPT. SEE ALSO
bash(1), csh(1), login(1), sh(1), tcsh(1), execve(2), clearenv(3), exec(3), getenv(3), putenv(3), setenv(3), unsetenv(3), locale(5) COLOPHON
This page is part of release 3.27 of the Linux man-pages project. A description of the project, and information about reporting bugs, can be found at http://www.kernel.org/doc/man-pages/. Linux 2009-07-25 ENVIRON(7)
Man Page