NETWORKS(5) BSD File Formats Manual NETWORKS(5)NAME
networks -- network name data base
The networks file contains information regarding the known networks which comprise the DARPA Internet. For each network a single line should
be present with the following information:
official network name
Items are separated by any number of blanks and/or tab characters. A ``#'' indicates the beginning of a comment; characters up to the end of
the line are not interpreted by routines which search the file. This file is normally created from the official network data base maintained
at the Network Information Control Center (NIC), though local changes may be required to bring it up to date regarding unofficial aliases
and/or unknown networks.
Network number may be specified in the conventional ``.'' (dot) notation using the inet_network(3) routine from the Internet address manipu-
lation library, inet(3). Network names may contain any printable character other than a field delimiter, newline, or comment character.
INTERACTION WITH DIRECTORY SERVICES
Processes generally find network records using one of the getnetent(3) family of functions. On Mac OS X, these functions interact with the
DirectoryService(8) daemon, which reads the /etc/networks file as well as searching other directory information services to determine network
name and address information.
SEE ALSO getnetent(3), DirectoryService(8)HISTORY
The networks file format appeared in 4.2BSD.
4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution
Check Out this Related Man Page
networks(4) Kernel Interfaces Manual networks(4)NAME
networks - network name data base
The file associates Internet (IP) addresses with official network names and aliases. This allows the user to refer to a network by a sym-
bolic name instead of using an Internet address. For each network, a single line should be present with the following information:
<official network name> <network number> <aliases>
Aliases are other names under which a network is known. For example:
where the network named is also called
A line cannot start with a blank (tab or space character). Items are separated by any number or combination of blanks. A character indi-
cates the beginning of a comment. Characters from the up to the end of the line are not interpreted by routines which search the file.
Trailing blanks are allowed at the end of a line. For the Internet, this file is normally created from the official network database main-
tained at the Network Information Control Center (NIC), though local changes may be required to bring it up-to-date regarding unofficial
aliases and/or unknown networks.
Network numbers can be specified in conventional Internet dot notation using the routine from the internet address manipulation library
(see inet(3N). Network names can contain any printable character other than a white space, new-line, or comment character.
was developed by the University of California, Berkeley.
FILES SEE ALSO getnetent(3N).
I'm trying to find the syntax for running DBsurvey scripts in UNIX. This is for a Sprint's cellular network (Lucent hardware). I can't find anything in Sprint or Lucent documents. Can anyone help me? A simple script looks like this:
MATCH: field_name GE 1
OUTPUT: field_name1... (5 Replies)
Just need a little help I'm not sure wat I should do.
We have several little networks setup for testing different things. One of these networks we need to have running at full dulpex.
Right now we run 2 hubs (to go off to 2 differnt parts) and they are half dulpex hubs.
Is is... (1 Reply)
I have problem with network settings.
Where i can find network config ? I'm newbie, but i very want learn this OS.
I find :
But where i can write my IP-address and after reboot i be know that my server... (2 Replies)
Hello all, thinking and reading of networks always make me think, and I have some questions, let me draw a sketch of the network I have, and then I'll put the questions:
This is the big layout, now, the Linux Bridge has 3 NICS, two for making the bridge between the... (0 Replies)
hi i have data extracted in the following format ranging around 300000 to 800000 records in a text file , the format is of network data .
No. Time Source Destination Protocol
1 1998-06-05 17:20:23.569905 HP_61:aa:c9 HP_61:aa:c9 ... (1 Reply)
Good morning folks,
A good friend of mine has a network where every host has two paths to the file servers (two NICs & two networks for all hosts).
Normally speaking, one network will be used for regular application traffic - license servers, itunes library, collaboration tools - while the... (4 Replies)
I've read about BITNET, CompuServe... CompuServe was probably not a network but an online service. Are (were) there any other networks alternative to Internet? Does anyone have experience with them? Do they still exist, is it possible to access them over Internet? There seems not to be another way... (13 Replies)