XL(4) BSD Kernel Interfaces Manual XL(4)
xl -- 3Com Etherlink XL and Fast Etherlink XL Ethernet device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The xl driver provides support for PCI Ethernet adapters and embedded controllers based on the 3Com "boomerang," "cyclone," "hurricane" and
"tornado" bus-master Etherlink XL chips.
The Etherlink XL chips support built-in 10baseT, 10base2 and 10base5 transceivers as well as an MII bus for externally attached PHY trans-
ceivers. The 3c905 series typically uses a National Semiconductor NS 83840A 10/100 PHY for 10/100 Mbps support in full or half-duplex. The
3c905B adapters have built-in autonegotiation logic mapped onto the MII for compatibility with previous drivers. Fast Etherlink XL adapters
such as the 3c905-TX and 3c905B-TX are capable of 10 or 100Mbps data rates in either full or half duplex and can be manually configured for
any supported mode or automatically negotiate the highest possible mode with a link partner.
The xl driver supports the following media types:
autoselect Enable autoselection of the media type and options. Note that this option is only available with the 3c905 and 3c905B
adapters with external PHYs or built-in autonegotiation logic. For 3c900 adapters, the driver will choose the mode
specified in the EEPROM. The user can change this by adding media options to the /etc/rc.conf file.
10baseT/UTP Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or
10base5/AUI Enable AUI transceiver (available only on COMBO cards).
10base2/BNC Enable BNC coax transceiver (available only on COMBO cards).
The xl driver supports the following media options:
full-duplex Force full duplex operation
half-duplex Force half duplex operation.
Note that the 100baseTX media type is only available if supported by the adapter. For more information on configuring this device, see
The xl driver supports the following hardware:
o 3Com 3c900-TPO
o 3Com 3c900-COMBO
o 3Com 3c905-TX
o 3Com 3c905-T4
o 3Com 3c900B-TPO
o 3Com 3c900B-TPC
o 3Com 3c900B-FL
o 3Com 3c900B-COMBO
o 3Com 3c905B-T4
o 3Com 3c905B-TX
o 3Com 3c905B-FX
o 3Com 3c905B-COMBO
o 3Com 3c905C-TX
o 3Com 3c980, 3c980B, and 3c980C server adapters
o 3Com 3cSOHO100-TX OfficeConnect adapters
o 3Com 3c450 HomeConnect adapters
o 3Com 3c555, 3c556 and 3c556B mini-PCI adapters
o 3Com 3C3SH573BT, 3C575TX, 3CCFE575BT, 3CXFE575BT, 3CCFE575CT, 3CXFE575CT, 3CCFEM656, 3CCFEM656B, and 3CCFEM656C, 3CXFEM656, 3CXFEM656B,
and 3CXFEM656C CardBus adapters
o 3Com 3c905-TX, 3c905B-TX 3c905C-TX, 3c920B-EMB, and 3c920B-EMB-WNM embedded adapters
Both the 3C656 family of CardBus cards and the 3C556 family of MiniPCI cards have a built-in proprietary modem. Neither the xl driver nor
any other FreeBSD driver supports this modem.
xl%d: couldn't map memory A fatal initialization error has occurred.
xl%d: couldn't map interrupt A fatal initialization error has occurred.
xl%d: device timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
xl%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
xl%d: no memory for tx list The driver failed to allocate an mbuf for the transmitter ring when allocating a pad buffer or collapsing an
mbuf chain into a cluster.
xl%d: command never completed! Some commands issued to the 3c90x ASIC take time to complete: the driver is supposed to wait until the 'com-
mand in progress' bit in the status register clears before continuing. In rare instances, this bit may not clear. To avoid getting caught
in an infinite wait loop, the driver only polls the bit for a finite number of times before giving up, at which point it issues this message.
This message may be printed during driver initialization on slower machines. If you see this message but the driver continues to function
normally, the message can probably be ignored.
xl%d: chip is in D3 power state -- setting to D0 This message applies only to 3c905B adapters, which support power management. Some operat-
ing systems place the 3c905B in low power mode when shutting down, and some PCI BIOSes fail to bring the chip out of this state before con-
figuring it. The 3c905B loses all of its PCI configuration in the D3 state, so if the BIOS does not set it back to full power mode in time,
it will not be able to configure it correctly. The driver tries to detect this condition and bring the adapter back to the D0 (full power)
state, but this may not be enough to return the driver to a fully operational condition. If you see this message at boot time and the driver
fails to attach the device as a network interface, you will have to perform second warm boot to have the device properly configured.
Note that this condition only occurs when warm booting from another operating system. If you power down your system prior to booting
FreeBSD, the card should be configured correctly.
xl%d: WARNING: no media options bits set in the media options register! This warning may appear when using the driver on some Dell Latitude
docking stations with built-in 3c905-TX adapters. For whatever the reason, the 'MII available' bit in the media options register on this
particular equipment is not set, even though it should be (the 3c905-TX always uses an external PHY transceiver). The driver will attempt to
guess the proper media type based on the PCI device ID word. The driver makes a lot of noise about this condition because the author consid-
ers it a manufacturing defect.
xl%d: transmission error: %d
xl%d: tx underrun, increasing tx start threshold to %d bytes This message may appear while the adapter tunes its transmission buffers under
various load amounts and are mostly harmless. It is probably safe to ignore them.
altq(4), arp(4), cardbus(4), miibus(4), netintro(4), ng_ether(4), pccard(4), polling(4), ifconfig(8)
The xl device driver first appeared in FreeBSD 3.0.
The xl driver was written by Bill Paul <firstname.lastname@example.org>.
January 23, 2008 BSD