osx man page for stdin

Query: stdin

OS: osx

Section: 4

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

FD(4)							   BSD Kernel Interfaces Manual 						     FD(4)

NAME
fd, stdin, stdout, stderr -- file descriptor files
DESCRIPTION
The files /dev/fd/0 through /dev/fd/# refer to file descriptors which can be accessed through the file system. If the file descriptor is open and the mode the file is being opened with is a subset of the mode of the existing descriptor, the call: fd = open("/dev/fd/0", mode); and the call: fd = fcntl(0, F_DUPFD, 0); are equivalent. Opening the files /dev/stdin, /dev/stdout and /dev/stderr is equivalent to the following calls: fd = fcntl(STDIN_FILENO, F_DUPFD, 0); fd = fcntl(STDOUT_FILENO, F_DUPFD, 0); fd = fcntl(STDERR_FILENO, F_DUPFD, 0); Flags to the open(2) call other than O_RDONLY, O_WRONLY and O_RDWR are ignored.
FILES
/dev/fd/# /dev/stdin /dev/stdout /dev/stderr
SEE ALSO
tty(4)
BSD
June 9, 1993 BSD
Related Man Pages
fdescfs(5) - freebsd
dup(2) - redhat
mount_fdesc(8) - mojave
mount_fdesc(8) - netbsd
mount_fdesc(8) - osx
Similar Topics in the Unix Linux Community
How to clear the content of a pipe (STDIN) after it is written to another program?
Pipelining with tar
awk to use variable instead of stdin or file
Redirect string from bash stderr to user stdin
Help building a variable string from a keyword - character replacements!