dlb(7) [osf1 man page]
dlb(7) Miscellaneous Information Manual dlb(7) NAME
dlb, dlpi - STREAMS pseudodevice driver for bridging BSD Drivers to STREAMS SYNOPSIS
#include <sys/dlpihdr.h> #include <fcntl.h> fd = open ("/dev/streams/dlb", O_RDWR, 0); DESCRIPTION
The dlb STREAMS pseudodevice driver provides a communication path between BSD-style device drivers and STREAMS protocol stacks. The dlb STREAMS pseudodevice driver is the Stream end in a Stream that communicates with BSD-based device drivers. When the /dev/streams/dlb character device is open, a Stream is constructed between a Stream head and the dlb pseudodevice driver. After the Stream that is intended to communicate with the BSD-based driver or drivers is created, the protocol module or modules can be pushed onto it. Tru64 UNIX supports a subset of the Data Link Provider Interface (DLPI) connectionless mode of communication. The attach DLPI primitive is required to associate a particular physical point of attachment (PPA) with a Stream in Tru64 UNIX's implementation of the style 2 provider. On the write side, the dlb pseudodevice driver translates connectionless style 2 DLPI messages to the appropriate BSD ifnet interface mes- sages. On the read side, the user-bound Service Access Point (SAP) messages received from a selected PPA over BSD based driver or drivers are sent upstream. RELATED INFORMATION
Network Programmer's Guide specification in /usr/share/doclib/dlpi/dlpi.ps delim off dlb(7)
Check Out this Related Man Page
pcn(7D) Devices pcn(7D) NAME
pcn - AMD PCnet Ethernet controller device driver SYNOPSIS
/dev/pcn DESCRIPTION
The pcn Ethernet driver is a multi-threaded, loadable, clonable driver for the AMD PCnet family of Ethernet controllers that use the Generic LAN Driver (GLD) facility to implement the required STREAMS and Data Link Provider (see dlpi(7P)) interfaces. This driver supports a number of integrated motherboards and add-in adapters based on the AMD PCnet-ISA, PCnet-PCI, and PCnet-32 con- troller chips. The pcn driver functions include controller initialization, frame transmit and receive, functional addresses, promiscuous and multicast support, and error recovery and reporting. APPLICATION PROGRAMMING INTERFACE
The cloning character-special device, /dev/pcn, is used to access all PCnet devices installed in the system. pcn and DLPI The pcn driver uses the Solaris GLD module which handles all the STREAMS and DLPI specific functions of the driver. It is a style 2 DLPI driver and therefore supports only the connectionless mode of data transfer. Thus, a DLPI user should issue a DL_ATTACH_REQ primitive to select the device to be used. Valid DLPI primitives are defined in <sys/dlpi.h>. Refer to dlpi(7P) for more information. The device is initialized on the first attach and de-initialized (stopped) on the last detach. The values returned by the driver in the DL_INFO_ACK primitive in response to a DL_INFO_REQ from the user are: o Maximum SDU is 1500 (ETHERMTU - defined in <sys/ethernet.h>). o Minimum SDU is 0. o DLSAP address length is 8. o MAC type is DL_ETHER. o sap length value is -2, meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address. o Service mode is DL_CLDLS. o No optional quality of service (QOS) support is included at present, accordingly, the QOS fields are 0. o Provider style is DL_STYLE2. o Version is DL_VERSION_2. o Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF). Once in the DL_ATTACHED state, the user must send a DL_BIND_REQ to associate a particular Service Access Point (SAP) with the stream. Known Problems and Limitations o Occasional data corruption has occurred when pcn and pcscsi drivers in HP Vectra XU 5/90 and Compaq Deskpro XL systems are used under high network and SCSI loads. These drivers do not perform well in a production server. A possible workaround is to disable the pcn device with the system BIOS and use a separate add-in network interface. o The Solaris pcn driver does not support IRQ 4. FILES
/dev/pcn Character special device /kernel/drv/pcn.conf Configuration file ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |x86 | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), standards(5), dlpi(7P), streamio(7I) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 20 Oct 2000 pcn(7D)