Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

scsi_hba_tran_alloc(9f) [opensolaris man page]

scsi_hba_tran_alloc(9F) 				   Kernel Functions for Drivers 				   scsi_hba_tran_alloc(9F)

NAME
scsi_hba_tran_alloc, scsi_hba_tran_free - allocate and free transport structures SYNOPSIS
#include <sys/scsi/scsi.h> scsi_hba_tran_t *scsi_hba_tran_alloc(dev_info_t *dip, int flags); void scsi_hba_tran_free(scsi_hba_tran_t *hba_tran); INTERFACE LEVEL
Solaris architecture specific (Solaris DDI). PARAMETERS
dip Pointer to a dev_info structure, defining the HBA driver instance. flag Flag modifiers. The only possible flag value is SCSI_HBA_CANSLEEP (memory allocation may sleep). hba_tran Pointer to a scsi_hba_tran(9S) structure. DESCRIPTION
For scsi_hba_tran_alloc(): The scsi_hba_tran_alloc() function allocates a scsi_hba_tran(9S) structure for a HBA driver. The HBA must use this structure to register its transport vectors with the system by using scsi_hba_attach_setup(9F). If the flag SCSI_HBA_CANSLEEP is set in flags, scsi_hba_tran_alloc() may sleep when allocating resources; otherwise it may not sleep, and callers should be prepared to deal with allocation failures. For scsi_hba_tran_free(): The scsi_hba_tran_free() function is used to free the scsi_hba_tran(9S) structure allocated by scsi_hba_tran_alloc(). RETURN VALUES
The scsi_hba_tran_alloc() function returns a pointer to the allocated transport structure, or NULL if no space is available. CONTEXT
The scsi_hba_tran_alloc() function can be called from user, interrupt, or kernel context. Drivers must not allow scsi_hba_tran_alloc() to sleep if called from an interrupt routine. The scsi_hba_tran_free() function can be called from user, interrupt, or kernel context context. SEE ALSO
scsi_hba_attach_setup(9F), scsi_hba_tran(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 scsi_hba_tran_alloc(9F)

Check Out this Related Man Page

tran_tgt_init(9E)						Driver Entry Points						 tran_tgt_init(9E)

NAME
tran_tgt_init - request to initialize HBA resources on behalf of a particular target SYNOPSIS
#include <sys/scsi/scsi.h> void prefixtran_tgt_init(dev_info_t *hba_dip, dev_info_t *tgt_dip, scsi_hba_tran_t *hba_tran, struct scsi_device *sd); INTERFACE LEVEL
Solaris architecture specific (Solaris DDI). PARAMETERS
hba_dip Pointer to a dev_info_t structure, referring to the HBA device instance. tgt_dip Pointer to a dev_info_t structure, referring to the target device instance. hba_tran Pointer to a scsi_hba_tran(9S) structure, consisting of the HBA's transport vectors. sd Pointer to a scsi_device(9S) structure, describing the target. DESCRIPTION
The tran_tgt_init() vector in the scsi_hba_tran(9S) structure may be initialized during the HBA driver's attach(9E) to point to an HBA driver function to be called by the system when an instance of a target device is being created. The tran_tgt_init() vector, if not NULL,is called after the dev_info node structure is created for this target device instance, but before probe(9E) for this instance is called. Before receiving transport requests from the target driver instance, the HBA may perform any initialization required for this par- ticular target during the call of the tran_tgt_init() vector. Note that hba_tran will point to a cloned copy of the scsi_hba_tran_t structure allocated by the HBA driver if the SCSI_HBA_TRAN_CLONE flag was specified in the call to scsi_hba_attach(9F). In this case, the HBA driver may choose to initialize the tran_tgt_private field in the structure pointed to by hba_tran, to point to the data specific to the particular target device instance. RETURN VALUES
tran_tgt_init() must return: DDI_SUCCESS the HBA driver can support the addressed target, and was able to initialize per-target resources. DDI_FAILURE the HBA driver cannot support the addressed target, or was unable to initialize per-target resources. In this event, the initialization of this instance of the target device will not be continued, the target driver's probe(9E) will not be called, and the tgt_dip structure destroyed. SEE ALSO
attach(9E), probe(9E), tran_tgt_free(9E), tran_tgt_probe(9E), scsi_hba_attach_setup(9F), scsi_device(9S), scsi_hba_tran(9S) Writing Device Drivers SunOS 5.10 1 Nov 1993 tran_tgt_init(9E)
Man Page