net_netidtozonid(9F) Kernel Functions for Drivers net_netidtozonid(9F)
NAME
net_netidtozonid - map a netid_t structure identifier to a zoneid_t structure
SYNOPSIS
#include <sys/neti.h>
zoneid_t net_netidtozonid(const netid_t net);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
net valid netid_t structure that refers to an existing IP instance.
DESCRIPTION
The net_netidtozonid() function maps the given netid_t (used to represent an instance of IP) into the matching zoneid_t structure that is
associated with it.
RETURN VALUES
The net_netidtozonid() function returns -1 if no mapping took place. Otherwise, it returns the zoneid_t structure currently associated with
a netid_t structure. For shared stack zones, the zoneid_t structure for the global zone is returned.
CONTEXT
The net_netidtozonid() function may be called from user, kernel, or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes:
+-----------------------------+-----------------------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+-----------------------------+-----------------------------+
|Availability |SUNWcsu |
+-----------------------------+-----------------------------+
|Interface Stability |Committed |
+-----------------------------+-----------------------------+
SEE ALSO
net_zoneidtonetid(9F), attributes(5)
SunOS 5.11 1 May 2008 net_netidtozonid(9F)