Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_ispartialchecksum(9f) [opensolaris man page]

net_ispartialchecksum(9F)				   Kernel Functions for Drivers 				 net_ispartialchecksum(9F)

NAME
net_ispartialchecksum - indicate if a packet is being scheduled for hardware checksum calculation SYNOPSIS
#include <sys/neti.h> int net_ispartialchecksum(const net_data_t net, mblk_t *mb); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). mb the mblk structure holding a packet that is the subject of this query. DESCRIPTION
The net_ispartialchecksum() function looks at the fields within the mblk structure to determine if the packet contained inside contains headers with only partial checksum values. Partial checksum values are stored inside headers when the calculation of the complete checksum is being handled by the hardware. RETURN VALUES
The net_ispartialchecksum() function returns: -1 The network protocol does not support this function. 0 The packet does not contain partial checksums. If a packet is marked for hardware checksum'ing, the following values are returned: NET_HCK_L3_FULL Complete layer 3 checksum calculated NET_HCK_L3_PART Partial layer 3 checksum calculated NET_HCK_L4_FULL Complete layer 4 checksum calculated NET_HCK_L4_PART Partial layer 4 checksum calculated CONTEXT
The net_ispartialchecksum() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_isvalidchecksum(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_ispartialchecksum(9F)

Check Out this Related Man Page

net_isvalidchecksum(9F) 				   Kernel Functions for Drivers 				   net_isvalidchecksum(9F)

NAME
net_isvalidchecksum - verify layer 3 and layer 4 checksums SYNOPSIS
#include <sys/neti.h> int net_isvalidchecksum(const net_data_t net, mblk_t *mb); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). mb the mblk structure holding a packet that is the subject of this query. DESCRIPTION
The net_isvalidchecksum() function verifies the layer 3 checksum (and, in some case, the layer 4 checksum) in the packet. If possible, fields that are used by hardware checksum'ing are examined rather than manually verifying that the checksums are present for packets received from a network interface. For both IPv4 and IPv6, TCP, UDP and ICMP (including ICMPV6 for IPv6) layer 4 checksums are currently validated. RETURN VALUES
The net_isvalidchecksum() function returns: -1 The network protocol does not support this function. 0 The packet does not contain partial checksums. 1 The packet does contain partial checksums. CONTEXT
The net_isvalidchecksum() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_ispartialchecksum(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_isvalidchecksum(9F)
Man Page