Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_getmtu(9f) [opensolaris man page]

net_getmtu(9F)						   Kernel Functions for Drivers 					    net_getmtu(9F)

NAME
net_getmtu - determine the MTU of a given network interface SYNOPSIS
#include <sys/neti.h> int net_getmtu(const net_data_t net, const phy_if_t ifp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F). DESCRIPTION
The net_getmtu() function receives information about the current MTU of a network interface. The value returned from this function call should not be cached as the MTU of a network interface since it is not guaranteed to be constant. RETURN VALUES
The net_getmtu() function returns -1 if the network protocol does not support this feature and otherwise returns the current MTU of the network interface. CONTEXT
The net_getmtu() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F) SunOS 5.11 1 May 2008 net_getmtu(9F)

Check Out this Related Man Page

net_routeto(9F) 					   Kernel Functions for Drivers 					   net_routeto(9F)

NAME
net_routeto - indicate which network interface packets are sent SYNOPSIS
#include <sys/neti.h> phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address, struct sockaddr *nexthop); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). address network address to find a path out of the machine for. nexthop pointer to the sockaddr structure in which to store the address of the next hop. If this information is not required, the value NULL may be passed instead. DESCRIPTION
The net_routeto() function indicates which network interface packets destined for a particular address would be sent out of, according to the systems network routing tables. If next is supplied as a non-NULL pointer, the IP address of the nexthop router to be used is returned in it. RETURN VALUES
The net_routeto() function returns: -1 The network protocol does not support this function. 0 This function cannot find a route for the address given. >0 Indicates which network interface can be used to reach the given address. CONTEXT
The net_routeto() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_routeto(9F)
Man Page