Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ldi_get_eventcookie(9f) [opensolaris man page]

ldi_get_eventcookie(9F) 				   Kernel Functions for Drivers 				   ldi_get_eventcookie(9F)

NAME
ldi_get_eventcookie - retrieve NDI event service cookie SYNOPSIS
#include <sys/ddi_obsolete.h> int ldi_get_eventcookie(ldi_handle_t lh, char *name ddi_eventcookie_t *ecp); INTERFACE LEVEL
Obsolete PARAMETERS
ldi_handle_t lh Layered handle. char *name null-terminated string containing the event name. ddi_eventcookie_t *ecp Pointer to the kernel event cookie. DESCRIPTION
This function is obsolete and is only maintained for compatibility. Use of this function is strongly discouraged. For equivalent function- ality provided by new interfaces, see ldi_ev_get_cookie(9F) and ldi_ev_register_callbacks(9F). The ldi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that cookie. The search is performed by calling up the device tree hierarchy of the device represented by the layered driver handle until the request is satisfied by a bus nexus driver, or the top of the dev_info tree is reached. The cookie returned by this function can be used to register a callback handler with ldi_add_event_handler(9F). RETURN VALUES
DDI_SUCCESS Cookie handle is returned. DDI_FAILURE Request was not serviceable by any nexus driver in the target device's ancestral device tree hierarchy. CONTEXT
This function may be called from user or kernel contexts. SEE ALSO
ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F), ldi_add_event_handler(9F), ldi_remove_event_handler(9F) Writing Device Drivers SunOS 5.11 21 Aug 2007 ldi_get_eventcookie(9F)

Check Out this Related Man Page

ddi_add_event_handler(9F)				   Kernel Functions for Drivers 				 ddi_add_event_handler(9F)

NAME
ddi_add_event_handler - add an NDI event service callback handler SYNOPSIS
#include <sys/dditypes.h> #include <sys/sunddi.h> int ddi_add_event_handler(dev_info_t *dip, ddi_eventcookie_t cookie, void (*handler)(dev_info_t *, ddi_eventcookie_t, void *, void *), void *arg, ddi_registration_id_t *id); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dev_info_t *dip Device node registering the callback. ddi_eventcookie_t cookie Cookie returned from call to ddi_get_eventcookie(9F). void (*handler)(dev_info_t *, ddi_eventcookie_t, void *, void *) Callback handler responsible for handling an NDI event service notification. void *arg Pointer to opaque data supplied by the caller. Typically, this would be a pointer to the driver's softstate structure. ddi_registration_id_t *id Pointer to registration ID where a unique registration id will be returned. Registration ID must be saved and used when calling ddi_remove_event_handler(9F) to unregister a callback. DESCRIPTION
The ddi_add_event_handler() function adds a callback handler to be invoked in the face of the event specifed by cookie. The process of adding a callback handler is also known as subscribing to an event. Upon successful subscription, the handler will be invoked by the system when the event occurs. The handler can be unregistered by using ddi_remove_event_handler(9F). An instance of a driver can register multiple handlers for an event or a single handler for multiple events. Callback order is not defined and should assumed to be random. The routine handler will be invoked with the following arguments: dev_info_t *dip Device node requesting the notification. ddi_eventcookie_t cookie Structure describing event that occurred. void *arg Opaque data pointer provided, by the driver, during callback registration. void *impl_data Pointer to event specific data defined by the framework which invokes the callback function. RETURN VALUES
DDI_SUCCESS Callback handler registered successfully. DDI_FAILURE Failed to register callback handler. Possible reasons include lack of resources or a bad cookie. CONTEXT
The ddi_add_event_handler() and handler() function can be called from user and kernel contexts only. ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), ddi_get_eventcookie(9F), ddi_remove_event_handler(9F) Writing Device Drivers NOTES
Drivers must remove all registered callback handlers for a device instance by calling ddi_remove_event_handler(9F) before detach completes. SunOS 5.10 62 Nov 2003 ddi_add_event_handler(9F)
Man Page