ldi_get_eventcookie(9F) Kernel Functions for Drivers ldi_get_eventcookie(9F)NAME
ldi_get_eventcookie - retrieve NDI event service cookie
SYNOPSIS
#include <sys/ddi_obsolete.h>
int ldi_get_eventcookie(ldi_handle_t lh, char *name
ddi_eventcookie_t *ecp);
INTERFACE LEVEL
Obsolete
PARAMETERS
ldi_handle_t lh Layered handle.
char *name null-terminated string containing the event name.
ddi_eventcookie_t *ecp Pointer to the kernel event cookie.
DESCRIPTION
This function is obsolete and is only maintained for compatibility. Use of this function is strongly discouraged. For equivalent function-
ality provided by new interfaces, see ldi_ev_get_cookie(9F) and ldi_ev_register_callbacks(9F).
The ldi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that
cookie. The search is performed by calling up the device tree hierarchy of the device represented by the layered driver handle until the
request is satisfied by a bus nexus driver, or the top of the dev_info tree is reached.
The cookie returned by this function can be used to register a callback handler with ldi_add_event_handler(9F).
RETURN VALUES
DDI_SUCCESS Cookie handle is returned.
DDI_FAILURE Request was not serviceable by any nexus driver in the target device's ancestral device tree hierarchy.
CONTEXT
This function may be called from user or kernel contexts.
SEE ALSO ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F), ldi_add_event_handler(9F), ldi_remove_event_handler(9F)
Writing Device Drivers
SunOS 5.11 21 Aug 2007 ldi_get_eventcookie(9F)
Check Out this Related Man Page
ddi_get_eventcookie(9F) Kernel Functions for Drivers ddi_get_eventcookie(9F)NAME
ddi_get_eventcookie - retrieve a NDI event service cookie handle
SYNOPSIS
#include <sys/dditypes.h>
#include <sys/sunddi.h>
int ddi_get_eventcookie(dev_info_t *dip, char *name,
ddi_eventcookie_t *event_cookiep);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dev_info_t *dip
Child device node requesting the cookie.
char *name
NULL-terminated string containing the name of the event.
ddi_eventcookie_t *event_cookiep
Pointer to cookie where event cookie will be returned.
DESCRIPTION
The ddi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that
cookie. The search is performed by a calling up the device tree hierarchy until the request is satisfied by a bus nexus driver, or the top
of the dev_info tree is reached.
The cookie returned by this function can be used to register a callback handler, unregister a callback handler, or post an event.
RETURN VALUES
DDI_SUCCESS Cookie handle is returned.
DDI_FAILURE Request was not serviceable by any nexus driver in the driver's ancestral device tree hierarchy.
CONTEXT
The ddi_get_eventcookie() function can be called from user and kernel contexts only.
ATTRIBUTES
See attributes(5) for a description of the following attributes:
+-----------------------------+-----------------------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+-----------------------------+-----------------------------+
|Interface Stability |Committed |
+-----------------------------+-----------------------------+
SEE ALSO attributes(5), ddi_add_event_handler(9F), ddi_remove_event_handler(9F)
Writing Device Drivers
SunOS 5.11 6 Nov 2003 ddi_get_eventcookie(9F)
I have this code that doesnt do what it is suppose to do. It should block signal that I send while process is running. I press control+z while this process is running and it should be blocked but it isnt. When i press control+z it gives me this....
+ Stopped
When I change SIGTSP into SIGINT then... (5 Replies)
First question is how do you learn UNIX on a home lab. I understand that HP-UX isn't free and neither is SCO Unix and they don't run on x86 based systems anyways. The choices I believe are going to be OpenSolaris and FreeBSD. My question is UNIX commands the same across the board so if I learn... (11 Replies)
Hello all,
I am a newbie in shell scripting.
I want to know what does the below text means?
6.355u 1.679s 0:12.68 63.2% 0+0k 0+0io 0pf+0w
I am getting this line (on terminal) after every successful execution of my script.
Thanks in advance . . :)
-MD (15 Replies)
Hi all,
I hope you are fine,
I'd like study Os I tried a book like Silberschatz it's a good book but like
other books it talks about the concepts abstractly and that's due to it try
to encompass many concepts from many operating systems in GENERAL.
i am not too much comfortable from these... (20 Replies)
Hi,
Some of the process in th environment are producing a core file.
These core files are produced by default in the directory from which they were launched.
I want to change the default directory to say /tmp of that environment.
I am using both Linux and Solaris, so will need the solution... (2 Replies)
my request is:
i have to create a script , which will grep the 'not running' jobs and will send the update in mail with its name(job)
Scenario:
logged in to machine abc
went to particular path: cd /a/b/c
then ./script1.sh status (script.sh is a script,whose status gives info about 10 jobs... (1 Reply)
Hi all,
My home server was Solaris for quite a while- I started with an Ultra 2 about 20 years ago, ended with a Blade 2000- but I've transitioned to Linux and am not going back. I miss the Solaris experience a bit (but not the Oracle experience), besides running with modern and small and quiet... (0 Replies)
can anyone spot a problem with the below:
$
$ cat getopts.sh
#!/bin/sh
usage() { echo "myscript.sh local /tmp data.txt 600s -query" 1>&2; exit 1; }
while... (4 Replies)
All
I see cpu and memory usage are under control, only cache gets high upto 99% using sar -r command
I did echo3 and cleaned the drop caches
do we need to monitor this , why my application going high upto 99.8% memused in sar command , this is cache memory which is going high
will this... (12 Replies)
I have been trying to enable password complexity variables on Solaris 10 by editing the /etc/default/passwd file but none of my changes are taking effect (I'm still able to set passwords that violate the rules I am trying to implement).
I've tried an O/S reboot after the changes but that had no... (6 Replies)
Hello everyone, I am using centos,
1) solaris is free right?
2) I want to learn solaris and install it in a computer that I am mounting, I would like know what is strong in solaris and if do it is wise. I am programmer python, learning machine and programming in general,..any help thanks,.. (6 Replies)
Hello!
Yesterday we added over 10,000 PHP man pages to our man page section.
I've not yet got our unique and special recursive search feature working; but you can still access the PHP man pages directly by selecting PHP in the man sets drop down menu (left side) and then section 3 (right... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)