ldi_dump(9F) Kernel Functions for Drivers ldi_dump(9F)NAME
ldi_dump - Issue a dump request to a device
SYNOPSIS
#include <sys/sunldi.h>
int ldi_dump(ldi_handle_t lh, caddr_t addr, daddr_t blkno, int nblk);
PARAMETERS
lh Layered handle.
addr Area dump address.
blkno Block offset to dump memory.
nblk Number of blocks to dump.
DESCRIPTION
The ldi_dump() function passes a dump request to the device entry point specified by the layered handle. This operation is supported for
block devices.
RETURN VALUES
The ldi_dump() function returns 0 upon success. If a failure occurs before the request is passed on to the device, the possible return val-
ues are shown below. Otherwise any other error number may be returned by the device.
EINVAL Invalid input parameters.
ENOTSUP Operation is not supported for this device.
CONTEXT
These functions may be called from user or kernel context.
SunOS 5.11 3 June 2003 ldi_dump(9F)
Check Out this Related Man Page
dump(9E) Driver Entry Points dump(9E)NAME
dump - dump memory to device during system failure
SYNOPSIS
#include <sys/types.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>
int dump(dev_t dev, caddr_t addr, daddr_t blkno, int nblk);
INTERFACE LEVEL
Solaris specific (Solaris DDI). This entry point is required. For drivers that do not implement dump() routines, nodev(9F) should be used.
ARGUMENTS
dev Device number.
addr Address for the beginning of the area to be dumped.
blkno Block offset to dump memory.
nblk Number of blocks to dump.
DESCRIPTION
dump() is used to dump a portion of virtual address space directly to a device in the case of system failure. It can also be used for
checking the state of the kernel during a checkpoint operation. The memory area to be dumped is specified by addr (base address) and nblk
(length). It is dumped to the device specified by dev starting at offset blkno. Upon completion dump() returns the status of the transfer.
When the system is panicking, the calls of functions scheduled by timeout(9F) and ddi_trigger_softintr(9F) will never occur. Neither can
delay(9F) be relied upon, since it is implemented via timeout(). See ddi_in_panic(9F).
dump() is called at interrupt priority.
RETURN VALUES
dump() returns 0 on success, or the appropriate error number.
SEE ALSO cpr(7), nodev(9F)
Writing Device Drivers
SunOS 5.11 9 Oct 2001 dump(9E)
I have this code that doesnt do what it is suppose to do. It should block signal that I send while process is running. I press control+z while this process is running and it should be blocked but it isnt. When i press control+z it gives me this....
+ Stopped
When I change SIGTSP into SIGINT then... (5 Replies)
First question is how do you learn UNIX on a home lab. I understand that HP-UX isn't free and neither is SCO Unix and they don't run on x86 based systems anyways. The choices I believe are going to be OpenSolaris and FreeBSD. My question is UNIX commands the same across the board so if I learn... (11 Replies)
Hello all,
I am a newbie in shell scripting.
I want to know what does the below text means?
6.355u 1.679s 0:12.68 63.2% 0+0k 0+0io 0pf+0w
I am getting this line (on terminal) after every successful execution of my script.
Thanks in advance . . :)
-MD (15 Replies)
Hi all,
I hope you are fine,
I'd like study Os I tried a book like Silberschatz it's a good book but like
other books it talks about the concepts abstractly and that's due to it try
to encompass many concepts from many operating systems in GENERAL.
i am not too much comfortable from these... (20 Replies)
Hi,
Some of the process in th environment are producing a core file.
These core files are produced by default in the directory from which they were launched.
I want to change the default directory to say /tmp of that environment.
I am using both Linux and Solaris, so will need the solution... (2 Replies)
my request is:
i have to create a script , which will grep the 'not running' jobs and will send the update in mail with its name(job)
Scenario:
logged in to machine abc
went to particular path: cd /a/b/c
then ./script1.sh status (script.sh is a script,whose status gives info about 10 jobs... (1 Reply)
Hi all,
My home server was Solaris for quite a while- I started with an Ultra 2 about 20 years ago, ended with a Blade 2000- but I've transitioned to Linux and am not going back. I miss the Solaris experience a bit (but not the Oracle experience), besides running with modern and small and quiet... (0 Replies)
can anyone spot a problem with the below:
$
$ cat getopts.sh
#!/bin/sh
usage() { echo "myscript.sh local /tmp data.txt 600s -query" 1>&2; exit 1; }
while... (4 Replies)
All
I see cpu and memory usage are under control, only cache gets high upto 99% using sar -r command
I did echo3 and cleaned the drop caches
do we need to monitor this , why my application going high upto 99.8% memused in sar command , this is cache memory which is going high
will this... (12 Replies)
I have been trying to enable password complexity variables on Solaris 10 by editing the /etc/default/passwd file but none of my changes are taking effect (I'm still able to set passwords that violate the rules I am trying to implement).
I've tried an O/S reboot after the changes but that had no... (6 Replies)
Hello everyone, I am using centos,
1) solaris is free right?
2) I want to learn solaris and install it in a computer that I am mounting, I would like know what is strong in solaris and if do it is wise. I am programmer python, learning machine and programming in general,..any help thanks,.. (6 Replies)
Hello!
Yesterday we added over 10,000 PHP man pages to our man page section.
I've not yet got our unique and special recursive search feature working; but you can still access the PHP man pages directly by selecting PHP in the man sets drop down menu (left side) and then section 3 (right... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)