opensolaris man page for linkblk

Query: linkblk

OS: opensolaris

Section: 9s

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

linkblk(9S)						    Data Structures for Drivers 					       linkblk(9S)

NAME
linkblk - STREAMS data structure sent to multiplexor drivers to indicate a link
SYNOPSIS
#include <sys/stream.h>
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI)
DESCRIPTION
The linkblk structure is used to connect a lower Stream to an upper STREAMS multiplexor driver. This structure is used in conjunction with the I_LINK, I_UNLINK, P_LINK, and P_UNLINK ioctl commands. See streamio(7I). The M_DATA portion of the M_IOCTL message contains the linkblk structure. Note that the linkblk structure is allocated and initialized by the Stream head as a result of one of the above ioctl commands.
STRUCTURE MEMBERS
queue_t *l_qtop; /* lowest level write queue of upper stream */ /* (set to NULL for persistent links) */ queue_t *l_qbot; /* highest level write queue of lower stream */ int l_index; /* index for lower stream. */
SEE ALSO
ioctl(2), streamio(7I) STREAMS Programming Guide SunOS 5.11 7 Jul 1994 linkblk(9S)
Related Man Pages
wr(9f) - sunos
wr(9f) - redhat
wr(9f) - debian
wr(9f) - linux
wr(9f) - php
Similar Topics in the Unix Linux Community
Study UNIX Kernel
Change directory for core file
Grep the 'not running' jobs and will send the update in mail with its name(job)
What's legal and what's not?
Shopt -s histappend