opensolaris man page for ureadc

Query: ureadc

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ureadc(9F)						   Kernel Functions for Drivers 						ureadc(9F)

NAME
ureadc - add character to a uio structure
SYNOPSIS
#include <sys/uio.h> #include <sys/types.h> int ureadc(int c, uio_t *uio_p);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
c The character added to the uio(9S) structure. uio_p Pointer to the uio(9S) structure.
DESCRIPTION
The ureadc() function transfers the character c into the address space of the uio(9S) structure pointed to by uio_p, and updates the uio structure as for uiomove(9F).
RETURN VALUES
0 is returned on success and EFAULT on failure.
CONTEXT
The ureadc() function can be called from user, interrupt, or kernel context.
SEE ALSO
uiomove(9F), uwritec(9F), iovec(9S), uio(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 ureadc(9F)
Related Man Pages
write(9e) - opensolaris
read(9e) - opensolaris
uiomove(9) - netbsd
write(9e) - sunos
uiomove(9f) - sunos
Similar Topics in the Unix Linux Community
Trying to block signal
How to learn UNIX
PHP Man Pages Now Available (Over 10,000)
Change directory for core file
Solaris 10 - password complexity not working