opensolaris man page for swab

Query: swab

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

swab(9F)						   Kernel Functions for Drivers 						  swab(9F)

NAME
swab - swap bytes in 16-bit halfwords
SYNOPSIS
#include <sys/sunddi.h> void swab(void *src, void *dst, size_t nbytes);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
src A pointer to the buffer containing the bytes to be swapped. dst A pointer to the destination buffer where the swapped bytes will be written. If dst is the same as src the buffer will be swapped in place. nbytes Number of bytes to be swapped, rounded down to the nearest half-word.
DESCRIPTION
The swab() function copies the bytes in the buffer pointed to by src to the buffer pointer to by dst, swapping the order of adjacent bytes in half-word pairs as the copy proceeds. A total of nbytes bytes are copied, rounded down to the nearest half-word.
CONTEXT
The swab() function can be called from user, interrupt, or kernel context.
SEE ALSO
Writing Device Drivers
NOTES
Since swab() operates byte-by-byte, it can be used on non-aligned buffers. SunOS 5.11 16 Jan 2006 swab(9F)
Related Man Pages
uiomove(9f) - opensolaris
swab(3p) - suse
swab(3c) - opensolaris
strcpy(9f) - sunos
strlcat(9f) - sunos
Similar Topics in the Unix Linux Community
Endian Conversion
How to determince CD is bootable or not
FTP script variable issue
Problems burning DVD-RW media