opensolaris man page for scsi_hba_pkt_comp

Query: scsi_hba_pkt_comp

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_hba_pkt_comp(9F)													     scsi_hba_pkt_comp(9F)

NAME
scsi_hba_pkt_comp - scsi_pkt completion routine
SYNOPSIS
#include <sys/scsi/scsi.h> void scsi_hba_pkt_comp(struct scsi_pkt *pkt);
PARAMETERS
pkt Pointer to a scsi_pkt(9S) structure.
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
After filling in scsi_pkt(9S) fields with packet completion information, an HBA driver should call the scsi_hba_pkt_comp() function. This function is the recommended way for an HBA driver to signal completion of a scsi_pkt structure. Use is mandatory for HBA drivers that use tran_setup_pkt(9E). Calling the scsi_hba_pkt_comp() function allows SCSA to observe, and possibly react to, the completion of a scsi_pkt request. A call to the scsi_hba_pkt_comp() function will always result in a call to the pkt_comp() callback function defined in scsi_pkt(9S). This pkt_comp() callback may, however, occur after return from scsi_hba_pkt_comp(), and may occur from a different thread executing on a differ- ent CPU.
CONTEXT
The scsi_hba_pkt_comp() function can be called from user, interrupt, or kernel context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), tran_setup_pkt(9E), scsi_pkt(9S)
NOTES
HBA driver calls scsi_hba_pkt_comp() instead of calling scsi_pkt(9S) pkt_comp directly. SunOS 5.11 29 Jan 2009 scsi_hba_pkt_comp(9F)
Related Man Pages
tran_setup_pkt(9e) - opensolaris
scsi_hba_pkt_free(9f) - sunos
tran_pkt_constructor(9e) - opensolaris
tran_teardown_pkt(9e) - opensolaris
scsi_hba_pkt_alloc(9f) - php
Similar Topics in the Unix Linux Community
backward string cut