opensolaris man page for nvlist_remove

Query: nvlist_remove

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

nvlist_remove(9F)					   Kernel Functions for Drivers 					 nvlist_remove(9F)

NAME
nvlist_remove, nvlist_remove_all - remove name-value pairs
SYNOPSIS
#include <sys/nvpair.h> int nvlist_remove(nvlist_t *nvl, const char *name, data_type_t type); int nvlist_remove_all(nvlist_t *nvl, const char *name);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
nvl The list of name-value pairs (nvlist_t) to be processed. name Name of the name-value pair (nvpair) to be removed. type Data type of the nvpair to be removed.
DESCRIPTION
The nvlist_remove() function removes the first occurrence of nvpair that matches the name and the type. The nvlist_remove_all() function removes all occurrences of nvpair that match the name, regardless of type. Multiple threads can simultaneously read the same nvlist_t but only one thread may actively change a given nvlist_t at a time. The caller is responsible for the synchronization.
RETURN VALUES
These functions return 0 on success and an error value on failure.
CONTEXT
The nvlist_remove() and nvlist_remove_all() functions can be called from user, interrupt, or kernel context.
ERRORS
EINVAL There is an invalid argument. ENOENT No name-value pairs were found to match the criteria specified by name and type. SunOS 5.11 16 Jan 2006 nvlist_remove(9F)
Related Man Pages
nvlist_remove(3nvpair) - sunos
nvlist_next_nvpair(9f) - sunos
nvlist_remove_all(3nvpair) - opensolaris
nvlist_remove_all(9f) - opensolaris
nvpair_type(9f) - opensolaris
Similar Topics in the Unix Linux Community
How to learn UNIX
Grep the 'not running' jobs and will send the update in mail with its name(job)
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
Identify problem with while getopts
What is good?