opensolaris man page for noenable

Query: noenable

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

noenable(9F)						   Kernel Functions for Drivers 					      noenable(9F)

NAME
noenable - prevent a queue from being scheduled
SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> void noenable(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue.
DESCRIPTION
The noenable() function prevents the q from being scheduled for service by insq(9F), putq(9F) or putbq(9F) when enqueuing an ordinary pri- ority message. The queue can be re-enabled with the enableok(9F) function.
CONTEXT
The noenable() function can be called from user, interrupt, or kernel context.
SEE ALSO
enableok(9F), insq(9F), putbq(9F), putq(9F), qenable(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 noenable(9F)
Related Man Pages
enableok(9f) - sunos
putq(9f) - mojave
putq(9f) - linux
putq(9f) - redhat
putq(9f) - opendarwin
Similar Topics in the Unix Linux Community
Trying to block signal
Change directory for core file
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
Identify problem with while getopts
What is good?