opensolaris man page for net_routeto

Query: net_routeto

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

net_routeto(9F) 					   Kernel Functions for Drivers 					   net_routeto(9F)

NAME
net_routeto - indicate which network interface packets are sent
SYNOPSIS
#include <sys/neti.h> phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address, struct sockaddr *nexthop);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). address network address to find a path out of the machine for. nexthop pointer to the sockaddr structure in which to store the address of the next hop. If this information is not required, the value NULL may be passed instead.
DESCRIPTION
The net_routeto() function indicates which network interface packets destined for a particular address would be sent out of, according to the systems network routing tables. If next is supplied as a non-NULL pointer, the IP address of the nexthop router to be used is returned in it.
RETURN VALUES
The net_routeto() function returns: -1 The network protocol does not support this function. 0 This function cannot find a route for the address given. >0 Indicates which network interface can be used to reach the given address.
CONTEXT
The net_routeto() function may be called from user, kernel, or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_routeto(9F)
Related Man Pages
hook_pkt_event(9s) - opensolaris
net_getifname(9f) - opensolaris
net_getlifaddr(9f) - opensolaris
net_isvalidchecksum(9f) - opensolaris
net_ispartialchecksum(9f) - opensolaris
Similar Topics in the Unix Linux Community
Find LAN Address
Help with IBM 550 and HMC settings
Dumping network packets
Obtaining IP address from both my network interface
Multiple networks on same server