opensolaris man page for net_protocol_walk

Query: net_protocol_walk

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

net_protocol_walk(9F)					   Kernel Functions for Drivers 				     net_protocol_walk(9F)

NAME
net_protocol_walk - step through the list of registered network protocols
SYNOPSIS
#include <sys/neti.h> net_data_t *net_protocol_walk(net_data_t net);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F).
DESCRIPTION
The net_protocol_walk() function walks through all of the network protocols that have been registered with this interface. The initial call to net_protocol_walk() should be made by passing in NULL as the value for net. When this function returns NULL, the end of the list has been reached. A caller of net_protocol_walk() is required to walk through the entire list of network protocols, until NULL is returned or, when finished with using the value returned, pass it into a call to net_protocol_release(9F).
RETURN VALUES
The net_protocol_walk() function returns NULL when the end of the list is returned. Otherwise, it returns a non-NULL value as a token for being passed into other function calls within this interface.
CONTEXT
The net_protocol_walk() function may be called from user, kernel, or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
net_protocol_lookup(9F), net_protocol_release(9F), attributes(5) SunOS 5.11 1 May 2008 net_protocol_walk(9F)
Related Man Pages
net_getifname(9f) - opensolaris
net_protocol_lookup(9f) - opensolaris
net_lifgetnext(9f) - opensolaris
net_phygetnext(9f) - opensolaris
net_instance_protocol_unregister(9f) - opensolaris
Similar Topics in the Unix Linux Community
define IP protocols on network