opensolaris man page for net_kstat_delete

Query: net_kstat_delete

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

net_kstat_delete(9F)					   Kernel Functions for Drivers 				      net_kstat_delete(9F)

NAME
net_kstat_delete - remove a kstat for a specific instance of IP from the system
SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/neti.h> void net_kstat_delete(netid_t netid, kstat_t *ksp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
netid IP instance identifier. ksp Pointer to a currently installed kstat(9S) structure.
DESCRIPTION
The net_kstat_delete() function removes ksp from the kstat chain and frees all associated system resources. See kstat_delete(9F) for a com- plete discussion of this function.
RETURN VALUES
If successful, net_kstat_delete() returns a pointer to the allocated kstat. NULL is returned upon failure.
CONTEXT
The net_kstat_delete() function may be called from user, kernel, or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
kstat_create(9F), kstat_delete(9F), net_kstat_create(9F), hook_t(9S), kstat_named(9S) SunOS 5.11 1 May 2008 net_kstat_delete(9F)
Related Man Pages
kstat_lookup(3kstat) - opensolaris
kstat_create(9f) - opensolaris
ks_snapshot(9e) - sunos
ks_update(9e) - sunos
ks_snapshot(9e) - opensolaris
Similar Topics in the Unix Linux Community
remove space characters
where can i get the variable tree for kvm &amp; kstat