Query: mioc2ack
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
mioc2ack(9F) Kernel Functions for Drivers mioc2ack(9F)NAMEmioc2ack - Convert an M_IOCTL message to an M_IOCACK messageSYNOPSIS#include <sys/stream.h> #include <sys/strsun.h> void mioc2ack(mblk_t *mp, mblk_t *dp, size_t count, int rval);INTERFACE LEVELSolaris DDI specific (Solaris DDI).PARAMETERSmp M_IOCTL message. dp Payload to associate with M_IOCACK message. count Value to set the ioc_count of the iocblk(9S) to. rval Value to set the ioc_rval of the iocblk(9S) to.DESCRIPTIONThe mioc2ack() function converts an M_IOCTL message into an M_IOCACK message using the supplied arguments. To convert the message, mioc2ack() changes the message type to M_IOCACK, sets the ioc_count and ioc_rval members of the iocblk(9S) associ- ated with mp to the passed-in values, and clears the ioc_error field. Further, it frees any message blocks chained off of mp->b_cont and resets mp->b_cont to dp. Finally, if dp is not NULL, mioc2ack() resets dp->b_wptr to be dp->b_rptr + count (that is, it sets dp to be exactly count bytes in length).RETURN VALUESNone.CONTEXTThis function can be called from user, kernel or interrupt context.SEE ALSOmiocack(9F), miocnak(9F), iocblk(9S) STREAMS Programming Guide SunOS 5.11 9 June 2004 mioc2ack(9F)
Related Man Pages |
---|
mblkhead(9f) - sunos |
mcopyout(9f) - sunos |
mkiocb(9f) - sunos |
miocack(9f) - opensolaris |
mkiocb(9f) - opensolaris |
Similar Topics in the Unix Linux Community |
---|
Received duplicate M_IOCACK |