Query: makedevice
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
makedevice(9F) Kernel Functions for Drivers makedevice(9F)NAMEmakedevice - make device number from major and minor numbersSYNOPSIS#include <sys/types.h> #include <sys/mkdev.h> #include <sys/ddi.h> dev_t makedevice(major_t majnum, minor_t minnum);INTERFACE LEVELArchitecture independent level 1 (DDI/DKI).PARAMETERSmajnum Major device number. minnum Minor device number.DESCRIPTIONThe makedevice() function creates a device number from a major and minor device number. makedevice() should be used to create device num- bers so the driver will port easily to releases that treat device numbers differently.RETURN VALUESThe device number, containing both the major number and the minor number, is returned. No validation of the major or minor numbers is per- formed.CONTEXTThe makedevice() function can be called from user, interrupt, or kernel context.SEE ALSOgetmajor(9F), getminor(9F) SunOS 5.11 16 Jan 2006 makedevice(9F)
Related Man Pages |
---|
getmajor(9f) - minix |
getmajor(9f) - linux |
getmajor(9f) - bsd |
getmajor(9f) - debian |
getmajor(9f) - v7 |
Similar Topics in the Unix Linux Community |
---|
mknod system call to clone /dev/null |