opensolaris man page for ldi_get_size

Query: ldi_get_size

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_get_size(9F)					   Kernel Functions for Drivers 					  ldi_get_size(9F)

NAME
ldi_get_size - Retrieve device size
SYNOPSIS
#include <sys/sunldi.h> int ldi_get_size(ldi_handle_t lh, uint64_t *sizep);
PARAMETERS
lh Layered handle. sizep Pointer to the caller's unsigned 64-bit integer buffer.
DESCRIPTION
The ldi_get_size() function uses the layered driver handle to calculate and return a device's size. The device size is returned within the caller supplied buffer (*sizep). A valid layered driver handle must be obtained via the ldi_open_by_name(9F) interface prior to calling ldi_get_size().
RETURN VALUES
The ldi_get_size() function returns the following values: DDI_SUCCESS The device size has been returned within the caller supplied buffer. DDI_FAILURE The device size could not be found or determined.
CONTEXT
This function may be called from user or kernel context.
SEE ALSO
ldi_open_by_name(9F) Writing Device Drivers SunOS 5.11 18 Mar 2004 ldi_get_size(9F)
Related Man Pages
ldi_get_dev(9f) - sunos
ldi_get_devid(9f) - sunos
ldi_get_minor_name(9f) - sunos
ldi_get_eventcookie(9f) - sunos
ldi_get_eventcookie(9f) - opensolaris
Similar Topics in the Unix Linux Community
How to learn UNIX
Grep the 'not running' jobs and will send the update in mail with its name(job)
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
Solaris 10 - password complexity not working
What is good?