Query: ldi_aread
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
ldi_aread(9F) Kernel Functions for Drivers ldi_aread(9F)NAMEldi_aread, ldi_awrite - Issue an asynchronous read or write request to a deviceSYNOPSIS#include <sys/sunldi.h> int ldi_aread(ldi_handle_t lh, struct aio_req *aio_reqp, cred_t *cr); int ldi_awrite(ldi_handle_t lh, struct aio_req *aio_reqp, cred_t *cr);PARAMETERSlh Layered handle. cr Pointer to a credential structure. aio_reqp Pointer to the aio_req(9S) structure that describes where the data is to be stored or obtained from.DESCRIPTIONThe ldi_awrite() function passes an asynchronous write request to a device entry point specified by the layered handle. This operation is supported for block and character devices. The ldi_aread() function passes an asynchronous read request to a device entry point specified by the layered handle. This operation is supported for block and character devices.RETURN VALUESThe ldi_awrite() and ldi_aread() functions return 0 upon success. If a failure occurs before the request is passed on to the device, the possible return values are shown below. Otherwise any other error number may be returned by the device. EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device.CONTEXTThese functions may be called from user context. SunOS 5.11 3 June 2003 ldi_aread(9F)
Related Man Pages |
---|
awrite(9e) - opensolaris |
awrite(9e) - sunos |
ldi_write(9f) - sunos |
ldi_awrite(9f) - opensolaris |
ldi_read(9f) - opensolaris |
Similar Topics in the Unix Linux Community |
---|
Trying to block signal |
What does this mean? |
Change directory for core file |
Identify problem with while getopts |
Shopt -s histappend |