opensolaris man page for freerbuf

Query: freerbuf

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

freerbuf(9F)						   Kernel Functions for Drivers 					      freerbuf(9F)

NAME
freerbuf - free a raw buffer header
SYNOPSIS
#include <sys/buf.h> #include <sys/ddi.h> void freerbuf(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to a previously allocated buffer header structure.
DESCRIPTION
The freerbuf() function frees a raw buffer header previously allocated by getrbuf(9F). This function does not sleep and so may be called from an interrupt routine.
CONTEXT
The freerbuf() function can be called from user, interrupt, or kernel context.
SEE ALSO
getrbuf(9F), kmem_alloc(9F), kmem_free(9F), kmem_zalloc(9F) SunOS 5.11 16 Jan 2006 freerbuf(9F)
Related Man Pages
bioreset(9f) - sunos
bioreset(9f) - v7
bioreset(9f) - xfree86
bioreset(9f) - debian
bioreset(9f) - hpux
Similar Topics in the Unix Linux Community
Study UNIX Kernel
Grep the 'not running' jobs and will send the update in mail with its name(job)
What's legal and what's not?
Identify problem with while getopts
What is good?