opensolaris man page for ddi_get_driver_private

Query: ddi_get_driver_private

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_get_driver_private(9F)				   Kernel Functions for Drivers 				ddi_get_driver_private(9F)

NAME
ddi_get_driver_private, ddi_set_driver_private - get or set the address of the device's private data area
SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> void ddi_set_driver_private(dev_info_t *dip, void *data); void *ddi_get_driver_private(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
ddi_get_driver_private() dip Pointer to device information structure to get from. ddi_set_driver_private() dip Pointer to device information structure to set. data Data area address to set.
DESCRIPTION
The ddi_get_driver_private() function returns the address of the device's private data area from the device information structure pointed to by dip. The ddi_set_driver_private() function sets the address of the device's private data area in the device information structure pointed to by dip with the value of data.
RETURN VALUES
The ddi_get_driver_private() function returns the contents of devi_driver_data. If ddi_set_driver_private() has not been previously called with dip, an unpredictable value is returned.
CONTEXT
These functions can be called from user , interrupt, or kernel context.
SEE ALSO
Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_get_driver_private(9F)
Related Man Pages
ddi_dev_is_sid(9f) - opensolaris
ddi_get_driver_private(9f) - opensolaris
ddi_dev_is_sid(9f) - redhat
ddi_dev_is_sid(9f) - mojave
ddi_dev_is_sid(9f) - osx
Similar Topics in the Unix Linux Community
How to learn UNIX
Study UNIX Kernel
Grep the 'not running' jobs and will send the update in mail with its name(job)
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
Solaris 10 - password complexity not working