Query: ddi_btop
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
ddi_btop(9F) Kernel Functions for Drivers ddi_btop(9F)NAMEddi_btop, ddi_btopr, ddi_ptob - page size conversionsSYNOPSIS#include <sys/ddi.h> #include <sys/sunddi.h> unsigned long ddi_btop(dev_info_t *dip, unsigned long bytes); unsigned long ddi_btopr(dev_info_t *dip, unsigned long bytes); unsigned long ddi_ptob(dev_info_t *dip, unsigned long pages);INTERFACE LEVELSolaris DDI specific (Solaris DDI).DESCRIPTIONThis set of routines use the parent nexus driver to perform conversions in page size units. The ddi_btop() function converts the given number of bytes to the number of memory pages that it corresponds to, rounding down in the case that the byte count is not a page multiple. The ddi_btopr() function converts the given number of bytes to the number of memory pages that it corresponds to, rounding up in the case that the byte count is not a page multiple. The ddi_ptob() function converts the given number of pages to the number of bytes that it corresponds to. Because bus nexus may possess their own hardware address translation facilities, these routines should be used in preference to the corre- sponding DDI/DKI routines btop(9F), btopr(9F), and ptob(9F), which only deal in terms of the pagesize of the main system MMU.RETURN VALUESThe ddi_btop() and ddi_btopr() functions return the number of corresponding pages. ddi_ptob() returns the corresponding number of bytes. There are no error return values.CONTEXTThis function can be called from user, interrupt, or kernel context.EXAMPLESExample 1 Find the size (in bytes) of one page pagesize = ddi_ptob(dip, 1L);SEE ALSObtop(9F), btopr(9F), ptob(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_btop(9F)
Related Man Pages |
---|
ddi_poke(9f) - sunos |
ddi_poke16(9f) - sunos |
ddi_poke8(9f) - sunos |
ddi_pokec(9f) - opensolaris |
ddi_pokel(9f) - opensolaris |
Similar Topics in the Unix Linux Community |
---|
Trying to block signal |
How to learn UNIX |
What does this mean? |
Study UNIX Kernel |
What is good? |